summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-01-23 20:06:02 +0000
committerDaniel Bermond2020-01-23 20:06:02 +0000
commit5497194f79cd5cf36c0f8cfbbe37dfff27827e29 (patch)
treeff08691a27ca56a19d4ff26ffff1e3c9d023fa28
parent0520740e8f263389d259545a742e7f6c114af8aa (diff)
downloadaur-5497194f79cd5cf36c0f8cfbbe37dfff27827e29.tar.gz
Add Intel Quick Sync Video support (added by repository package)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a54899f4b8db..f0d803a7d2c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffmpeg-git
pkgdesc = Complete solution to record, convert and stream audio and video (git version)
- pkgver = 4.2.r94300.gaf5f770113
+ pkgver = 4.3.r96479.g1001b6a750
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -23,6 +23,7 @@ pkgbase = ffmpeg-git
depends = libavc1394
depends = libdrm
depends = libiec61883
+ depends = libmfx
depends = libmodplug
depends = libomxil-bellagio
depends = libpulse
@@ -58,7 +59,8 @@ pkgbase = ffmpeg-git
depends = libx264.so
depends = libx265.so
depends = libxvidcore.so
- optdepends = ladspa: LADSPA filters
+ optdepends = intel-media-sdk: for Intel Quick Sync Video
+ optdepends = ladspa: for LADSPA filters
provides = libavcodec.so
provides = libavdevice.so
provides = libavfilter.so
diff --git a/PKGBUILD b/PKGBUILD
index 7bf4d57712df..1762ea654fd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
# Contributor: Kamran Mackey <kamranm1200@gmail.com>
# Contributor: richteer <richteer at lastprime.net>
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-pkgver=4.2.r94300.gaf5f770113
+pkgver=4.3.r96479.g1001b6a750
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
arch=('x86_64')
url='https://www.ffmpeg.org/'
license=('GPL3')
depends=('alsa-lib' 'aom' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
- 'jack' 'lame' 'libavc1394' 'libdrm' 'libiec61883' 'libmodplug'
+ 'jack' 'lame' 'libavc1394' 'libdrm' 'libiec61883' 'libmfx' 'libmodplug'
'libomxil-bellagio' 'libpulse' 'libraw1394' 'libsoxr' 'libssh' 'libtheora'
'libvdpau' 'libwebp' 'libx11' 'libxcb' 'libxext' 'libxml2' 'libxv'
'opencore-amr' 'openjpeg2' 'opus' 'sdl2' 'speex' 'v4l-utils' 'xz' 'zlib'
@@ -19,7 +19,8 @@ depends=('alsa-lib' 'aom' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls'
'libva-x11.so' 'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so' 'libvpx.so'
'libx264.so' 'libx265.so' 'libxvidcore.so')
makedepends=('git' 'ffnvcodec-headers' 'ladspa' 'nasm')
-optdepends=('ladspa: LADSPA filters')
+optdepends=('intel-media-sdk: for Intel Quick Sync Video'
+ 'ladspa: for LADSPA filters')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavutil.so' 'libpostproc.so' 'libswresample.so' 'libswscale.so'
'ffmpeg')
@@ -35,7 +36,7 @@ pkgver() {
local _shorthash
_version="$( git describe --tags --long | awk -F'-' '{ sub(/^n/, "", $1); print $1 }')"
- _revision="$( git describe --tags --match 'N' | awk -F'-' '{ printf $2 }')"
+ _revision="$( git describe --tags --match 'N' | awk -F'-' '{ print $2 }')"
_shorthash="$(git rev-parse --short HEAD)"
printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
@@ -65,6 +66,7 @@ build() {
--enable-libgsm \
--enable-libiec61883 \
--enable-libjack \
+ --enable-libmfx \
--enable-libmodplug \
--enable-libmp3lame \
--enable-libopencore_amrnb \
@@ -97,9 +99,6 @@ build() {
}
package() {
- cd ffmpeg
-
- make DESTDIR="$pkgdir" install
-
- install -D -m755 tools/qt-faststart -t "${pkgdir}/usr/bin"
+ make -C ffmpeg DESTDIR="$pkgdir" install
+ install -D -m755 ffmpeg/tools/qt-faststart -t "${pkgdir}/usr/bin"
}