summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Viallon2020-10-21 22:42:02 +0200
committerAntoine Viallon2020-10-21 22:42:02 +0200
commit8c1a4df4bf8203db3470935618f0aee7ca418be8 (patch)
tree74d2f02fc623bc5103d07bd8d911b4c83171cd77
parentc8be66ff35f2330c5bc0a46d174ca269c20f0a9e (diff)
downloadaur-8c1a4df4bf8203db3470935618f0aee7ca418be8.tar.gz
Initial commit based on ffmpeg-git
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 336014a7f95c..372466621096 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = ffmpeg-git
- pkgdesc = Complete solution to record, convert and stream audio and video (git version)
- pkgver = 4.4.r99044.gd1f3d721df
+pkgbase = ffmpeg-nox-git
+ pkgdesc = Complete solution to record, convert and stream audio and video (git version, without X dependencies, for headless systems)
+ pkgver = 4.4.r99430.g9d8f9b2e40
pkgrel = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -37,15 +37,12 @@ pkgbase = ffmpeg-git
depends = libssh
depends = libtheora
depends = libva.so
- depends = libva-drm.so
- depends = libva-x11.so
depends = libvdpau
depends = libvidstab.so
depends = libvorbisenc.so
depends = libvorbis.so
depends = libvpx.so
depends = libwebp
- depends = libx11
depends = libx264.so
depends = libx265.so
depends = libxcb
@@ -82,5 +79,5 @@ pkgbase = ffmpeg-git
sha256sums = SKIP
sha256sums = 52778c70d9fe6e3a10941b99b96ac7749cec325dc1b9ee11ab75332b5ff68e50
-pkgname = ffmpeg-git
+pkgname = ffmpeg-nox-git
diff --git a/PKGBUILD b/PKGBUILD
index 92d1b16401fd..1573b40ab7ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer : Daniel Bermond <dbermond@archlinux.org>
+# Maintainer: Antoine Viallon <antoine@lesviallon.fr>
+# Contributor : Daniel Bermond <dbermond@archlinux.org>
# Contributor: Kamran Mackey <kamranm1200@gmail.com>
# Contributor: richteer <richteer at lastprime.net>
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
-pkgname=ffmpeg-git
-pkgver=4.4.r99044.gd1f3d721df
+pkgname=ffmpeg-nox-git
+pkgver=4.4.r99691.g1bf86ee907
pkgrel=1
-pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
+pkgdesc='Complete solution to record, convert and stream audio and video (git version, without X dependencies, for headless systems)'
arch=('x86_64')
url='https://www.ffmpeg.org/'
license=('GPL3')
@@ -37,16 +38,13 @@ depends=(
'libsoxr'
'libssh'
'libtheora'
- 'libva.so'
- 'libva-drm.so'
- 'libva-x11.so'
+ 'libva'
'libvdpau'
'libvidstab.so'
'libvorbisenc.so'
'libvorbis.so'
'libvpx.so'
'libwebp'
- 'libx11'
'libx264.so'
'libx265.so'
'libxcb'
@@ -95,9 +93,9 @@ pkgver() {
build() {
cd ffmpeg
-
+
printf '%s\n' ' -> Running ffmpeg configure script...'
-
+
./configure \
--prefix='/usr' \
--disable-debug \