summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-03-21 10:39:48 +0100
committertytan6522022-03-21 10:39:48 +0100
commit5d348f750704ae16c3afb8f22daddcf99882bc66 (patch)
tree516d39a86ba2c7c00300b265bc4a50658e8bb34f
parent533ebad4a1789dae29aa711e2c5d57de3a9f2cd6 (diff)
downloadaur-5d348f750704ae16c3afb8f22daddcf99882bc66.tar.gz
build: Add ffmpeg-full avisynth and svt-av1 fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c715a069d5a..cd148b4d1c4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-obs
pkgdesc = Complete solution to record, convert and stream audio and video with fixes for OBS Studio. And various options in the PKGBUILD
pkgver = 5.0
- pkgrel = 4
+ pkgrel = 5
url = https://ffmpeg.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 4085341814d1..882cffd6d764 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -60,7 +60,7 @@ DISTRIB_ID=`lsb_release --id | cut -f2 -d$'\t'`
pkgname=ffmpeg-obs
pkgver=5.0
-pkgrel=4
+pkgrel=5
pkgdesc='Complete solution to record, convert and stream audio and video with fixes for OBS Studio. And various options in the PKGBUILD'
arch=('i686' 'x86_64' 'aarch64')
url=https://ffmpeg.org/
@@ -434,6 +434,18 @@ fi
prepare() {
cd ffmpeg
+ ### ffmpeg-full changes
+
+ ## Fixes for SVT-AV1 0.9.0
+ # avcodec/libsvtav1: add a svtav1-params option to pass a list of key=value parameters
+ # https://github.com/FFmpeg/FFmpeg/commit/c33b4048859a191acf9b6aa22acaea248a4eb18f
+ git cherry-pick -n c33b4048859a191acf9b6aa22acaea248a4eb18f
+ # avcodec/libsvtav1: update some options and defaults
+ # https://github.com/FFmpeg/FFmpeg/commit/1dddb930aaf0cadaa19f86e81225c9c352745262
+ git cherry-pick -n 1dddb930aaf0cadaa19f86e81225c9c352745262
+ ## Fix segfault with avisynthplus
+ sed -i 's/RTLD_LOCAL/RTLD_DEEPBIND/g' libavformat/avisynth.c
+
### Arch Linux changes
## https://crbug.com/1251779
@@ -467,6 +479,8 @@ prepare() {
sed -i 's/FF_LIBRIST_FIFO_DEFAULT)/FF_LIBRIST_FIFO_DEFAULT_SHIFT)/g' libavformat/librist.c
sed -i 's/fifo_buffer_size/fifo_shift/g' libavformat/librist.c
+ ### Package features changes
+
## NDI changes if enabled
if [[ $FFMPEG_OBS_NDI == 'ON' ]]; then
patch -Np1 -i "${srcdir}"/Revert-lavd-Remove-libndi_newtek.patch