summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522024-06-22 12:30:23 +0200
committertytan6522024-06-22 12:30:35 +0200
commit741c45614fcf118ccf4f425c4868e439c52abb98 (patch)
treef977f18872d84568a355b696b7656a5b66e2706d
parent2b6105b26f16a6ba5cb3d783dedf559d3f24bd53 (diff)
downloadaur-741c45614fcf118ccf4f425c4868e439c52abb98.tar.gz
fix: Support x86_64 version in CARCH checks
Also fixes SVT HEVC and VP9 patch hashes.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e2b932091cf..dd30e4e916ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-obs
pkgdesc = Complete solution to record, convert and stream audio and video with fixes for OBS Studio. And various options in the PKGBUILD
pkgver = 7.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://ffmpeg.org/
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index 2c51778b3349..c10a39a1735b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,7 +52,7 @@ fi
pkgname=ffmpeg-obs
pkgver=7.0.1
-pkgrel=1
+pkgrel=2
pkgdesc='Complete solution to record, convert and stream audio and video with fixes for OBS Studio. And various options in the PKGBUILD'
arch=('x86_64' 'aarch64')
url=https://ffmpeg.org/
@@ -289,7 +289,7 @@ depends+=("librist>=$_libristver")
_args+=(--enable-librist)
## Add upstream feature for x86_64 build
-if [[ $CARCH == 'x86_64' ]]; then
+if [[ ${CARCH/%_v?/} == "x86_64" ]]; then
_args+=(--enable-lto --enable-libsvtav1)
depends+=("svt-av1>=$_svtav1ver")
else
@@ -297,7 +297,7 @@ else
fi
## Add upstream feature for i686 and x86_64 build
-if [[ $CARCH == "i686" || $CARCH == "x86_64" ]]; then
+if [[ $CARCH == "i686" || ${CARCH/%_v?/} == "x86_64" ]]; then
_args+=(--enable-libvmaf)
depends+=("vmaf>=$_vmafver")
fi
@@ -349,9 +349,9 @@ if [[ $FFMPEG_OBS_SVT == 'ON' ]]; then
"040-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/${_svt_vp9_ver}/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch"
)
sha256sums+=(
- 'e8fdc940474f3819b9a8d30cab8164774584c051322acb6194bcb03d56e8175a'
+ '9047e18d34716812d4ea7eafc1d0fd8b376d922a4b6b4dc20237662fcaf0c996'
'a164ebdc4d281352bf7ad1b179aae4aeb33f1191c444bed96cb8ab333c046f81'
- '0433016c8523c7ce159523946a76c8fa06a926f33f94b70e8de7c2082d14178c'
+ '59da61f2b2c556fbe0cdbf84bcc00977ee3d2447085decb21f6298226559f2aa'
)
_args+=(--enable-libsvthevc --enable-libsvtvp9)
provides+=(ffmpeg-svt-hevc ffmpeg-svt-vp9)