summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522024-02-09 19:52:15 +0100
committertytan6522024-02-09 19:52:15 +0100
commitfc1102e517a5a73b758a91dadbd87d18331cbc38 (patch)
tree1b358e880ac658d99676a3a0e97fe690d98afd4f
parentc419d4d972fca75e4dbc04664e102b3287551e75 (diff)
downloadaur-fc1102e517a5a73b758a91dadbd87d18331cbc38.tar.gz
build: Add vapoursynth support like upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71ef7b94ed2d..24e2088b5df8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = ffmpeg-obs
pkgdesc = Complete solution to record, convert and stream audio and video with fixes for OBS Studio. And various options in the PKGBUILD
pkgver = 6.1.1
- pkgrel = 5
+ pkgrel = 6
url = https://ffmpeg.org/
arch = x86_64
arch = aarch64
- license = GPL3
+ license = GPL-3.0-only
makedepends = git
+ makedepends = perl
makedepends = amf-headers
makedepends = avisynthplus
makedepends = clang
@@ -73,6 +74,7 @@ pkgbase = ffmpeg-obs
depends = snappy
depends = speex
depends = v4l-utils
+ depends = vapoursynth
depends = vulkan-icd-loader
depends = x264>=0.164
depends = x265>=3.5
diff --git a/PKGBUILD b/PKGBUILD
index fed8c6732a27..c055ef18833f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,11 +52,11 @@ fi
pkgname=ffmpeg-obs
pkgver=6.1.1
-pkgrel=5
+pkgrel=6
pkgdesc='Complete solution to record, convert and stream audio and video with fixes for OBS Studio. And various options in the PKGBUILD'
arch=('x86_64' 'aarch64')
url=https://ffmpeg.org/
-license=(GPL3)
+license=(GPL-3.0-only)
# To manage dependency rebuild easily, this will prevent you to rebuild FFmpeg on non-updated system
# Only for default set of features
_aomver=3
@@ -131,6 +131,7 @@ depends=(
snappy
speex
v4l-utils
+ vapoursynth
vulkan-icd-loader
"x264>=$_x264ver"
"x265>=$_x265ver"
@@ -141,6 +142,7 @@ depends=(
)
makedepends=(
git
+ perl
amf-headers
avisynthplus
clang
@@ -254,6 +256,7 @@ _args=(
--enable-opencl
--enable-opengl
--enable-shared
+ --enable-vapoursynth
--enable-version3
--enable-vulkan
)
@@ -369,7 +372,7 @@ if [[ $FFMPEG_OBS_FULL == 'ON' ]]; then
rtmpdump 'shine' smbclient tesseract
twolame 'uavs3d-git' 'vo-amrwbenc' 'xavs' 'xavs2' zeromq
zvbi lv2 lilv libmysofa openal
- vapoursynth libomxil-bellagio 'rockchip-mpp' #'pocketsphinx'
+ libomxil-bellagio 'rockchip-mpp' #'pocketsphinx'
lcms2 libraw1394 openvino libaribcaption opencv2
)
_args+=(
@@ -380,7 +383,7 @@ if [[ $FFMPEG_OBS_FULL == 'ON' ]]; then
--enable-librtmp --enable-libshine --enable-libsmbclient --enable-libtesseract
--enable-libtwolame --enable-libuavs3d --enable-libvo-amrwbenc --enable-libxavs --enable-libxavs2 --enable-libzmq
--enable-libzvbi --enable-lv2 --enable-libmysofa --enable-openal
- --enable-vapoursynth --enable-omx --enable-rkmpp #--enable-pocketsphinx
+ --enable-omx --enable-rkmpp #--enable-pocketsphinx
--enable-lcms2 --enable-libopenvino --enable-libaribcaption --enable-libopencv
)
provides+=(ffmpeg-full)