summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrancoism902018-05-17 16:06:08 +0200
committerfrancoism902018-05-17 16:06:08 +0200
commit2c7002dbc1ec89e2b276010aefcbf611eaab4b77 (patch)
tree8c98ba093ceb09fb54fa42dba7d2b5fef372dc1f
parent457fadc536e3a1654c1003814275429796eddab6 (diff)
downloadaur-2c7002dbc1ec89e2b276010aefcbf611eaab4b77.tar.gz
Fix missing license
-rw-r--r--.SRCINFO2
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD29
3 files changed, 26 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b71f2034e4b..2b7cd2e16c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -106,7 +106,9 @@ pkgbase = ffmpeg-qsv
conflicts = ffmpeg-semifull-git
conflicts = ffmpeg-qsv-git
source = https://ffmpeg.org/releases/ffmpeg-4.0.tar.xz
+ source = LICENSE
sha256sums = ed945daf40b124e77a685893cc025d086f638bc703183460aff49508edb3a43f
+ sha256sums = 04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36
pkgname = ffmpeg-qsv
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 00000000000..b0bb658ca78
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+This software is nonfree and unredistributable.
+
+The end-user must compile this software for himself in order to be allowed to use it.
+
+This software cannot be redistributed.
+
+This software cannot be used commercially.
+
+Due to the libraries used to compile this software, the resulting binaries and libraries are under a complex and restrictive license mix.
diff --git a/PKGBUILD b/PKGBUILD
index b7164bf4246..d6184924fb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,8 +31,9 @@ provides=('ffmpeg' 'ffmpeg-libfdk_aac' 'qt-faststart' 'libavutil.so' 'libavcodec
conflicts=(
'ffmpeg' 'ffmpeg-full-nvenc' 'ffmpeg-nvenc' 'ffmpeg-libfdk_aac' 'ffmpeg-decklink'
'ffmpeg-git' 'ffmpeg-full-git' 'ffmpeg-semifull-git' 'ffmpeg-qsv-git')
-source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz")
-sha256sums=('ed945daf40b124e77a685893cc025d086f638bc703183460aff49508edb3a43f')
+source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz" 'LICENSE')
+sha256sums=('ed945daf40b124e77a685893cc025d086f638bc703183460aff49508edb3a43f'
+ '04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
prepare() {
cd "${_srcname}-${pkgver}"
@@ -45,7 +46,7 @@ build() {
./configure \
--prefix='/usr' \
- --extra-libs='-lpthread' \
+ --extra-libs='-lpthread' \
--disable-debug \
--disable-rpath \
--enable-gpl \
@@ -56,7 +57,7 @@ build() {
--enable-gray \
--enable-avisynth \
--enable-avresample \
- --enable-alsa \
+ --enable-alsa \
--enable-fontconfig \
--enable-gmp \
--enable-gnutls \
@@ -77,14 +78,14 @@ build() {
--enable-libpulse \
--enable-libsoxr \
--enable-libspeex \
- --enable-libsrt \
+ --enable-libsrt \
--enable-libssh \
- --enable-librsvg \
- --enable-librtmp \
- --enable-libsmbclient \
+ --enable-librsvg \
+ --enable-librtmp \
+ --enable-libsmbclient \
--enable-libtheora \
- --disable-libtls \
- --enable-libtwolame \
+ --disable-libtls \
+ --enable-libtwolame \
--enable-libv4l2 \
--enable-libvidstab \
--enable-libvorbis \
@@ -96,15 +97,15 @@ build() {
--enable-libxcb \
--enable-libxml2 \
--enable-libxvid \
- --enable-lzma \
+ --enable-lzma \
--enable-libdrm \
- --enable-xlib \
+ --enable-xlib \
--enable-zlib \
--enable-omx \
- --enable-openal \
+ --enable-openal \
--enable-opencl \
--enable-opengl \
- --disable-openssl \
+ --disable-openssl \
--enable-libfdk_aac \
--enable-libmfx \
--enable-vaapi \