summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKamran Mackey2016-07-04 17:59:43 -0600
committerKamran Mackey2016-07-04 17:59:43 -0600
commite7e321256c8aa855f7f428b7a51ea8836cb7c84a (patch)
treee15726fa050b86f33e121d6f9ca83e9d853f3796
parent396e3f3b7a7cc17c41a1126f5590285326731759 (diff)
downloadaur-e7e321256c8aa855f7f428b7a51ea8836cb7c84a.tar.gz
Fixed build issues.
Signed-off-by: Kamran Mackey <kamranm1200@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c432ca3aaa82..b34eaa3e2ef8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jul 4 22:54:21 UTC 2016
+# Mon Jul 4 23:59:42 UTC 2016
pkgbase = ffmpeg-git
pkgdesc = Complete solution to record, convert and stream audio and video (git version)
- pkgver = r77492.f16e4a0
+ pkgver = 3.2.r80913.gce466d0
pkgrel = 1
url = http://ffmpeg.org/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 8e1c2161f1b4..bce449e67667 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-pkgver=r77492.f16e4a0
+pkgver=3.2.r80913.gce466d0
pkgrel=1
pkgdesc="Complete solution to record, convert and stream audio and video (git version)"
arch=('i686' 'x86_64')
@@ -11,25 +11,25 @@ license=('GPL3')
url="http://ffmpeg.org/"
depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gmp' 'gnutls' 'gsm' 'lame'
'libass' 'libavc1394' 'libbluray' 'libiec61883' 'libmodplug' 'libpulse'
- 'libsoxr' 'libssh' 'libtheora' 'libva' 'libvdpau' 'libwebp'
- 'netcdf' 'opencore-amr' 'openjpeg' 'opus' 'schroedinger' 'sdl' 'speex'
- 'v4l-utils' 'xvidcore' 'zlib' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
- 'libvpx.so' 'libx264.so' 'libx265.so')
+ 'libsoxr' 'libssh' 'libtheora' 'libva' 'libvdpau' 'libwebp'
+ 'netcdf' 'opencore-amr' 'openjpeg' 'opus' 'schroedinger' 'sdl' 'speex'
+ 'v4l-utils' 'xvidcore' 'zlib' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
+ 'libvpx.so' 'libx264.so' 'libx265.so')
makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
optdepends=('ladspa: LADSPA filters')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
- 'libswscale.so')
+ 'libswscale.so')
conflicts=('ffmpeg' 'ffmpeg-full-git')
source=("$pkgname"::'git://source.ffmpeg.org/ffmpeg.git')
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- _ver="$(git describe --tags | sed 's|-[^-]*$||' | sed 's|^n||')"
- _rev="$(git rev-list --count HEAD)"
- _gitid="$(git rev-parse --short HEAD)"
- echo "${_ver}.r${_rev}.g${_gitid}"
+ cd "$srcdir/$pkgname"
+ _ver="$(git describe --tags | sed 's|-[^.]*$||' | sed 's|^n||')"
+ _rev="$(git rev-list --count HEAD)"
+ _gitid="$(git rev-parse --short HEAD)"
+ echo "${_ver}.r${_rev}.g${_gitid}"
}
build() {
@@ -47,7 +47,6 @@ build() {
--enable-ladspa \
--enable-libass \
--enable-libbluray \
- --enable-libfdk-aac \
--enable-libfreetype \
--enable-libfribidi \
--enable-libgsm \