summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHui Yiqun2018-07-29 05:09:50 +0800
committerHui Yiqun2018-07-29 05:12:07 +0800
commit5743f28ee9bb50826b0e31e6c12d47a5b985dd02 (patch)
tree670c640e21dcb2055475a6d21cf027172ab133f5
downloadaur-5743f28ee9bb50826b0e31e6c12d47a5b985dd02.tar.gz
initial commit
-rw-r--r--.SRCINFO79
-rw-r--r--PKGBUILD99
-rw-r--r--fs56089.patch84
3 files changed, 262 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7282a52407f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,79 @@
+pkgbase = ffmpeg-tmblock-git
+ pkgdesc = Complete solution to record, convert and stream audio and video, with TMBlock support
+ pkgver = r91177.970872f23a
+ pkgrel = 2
+ epoch = 1
+ url = http://ffmpeg.org/
+ arch = x86_64
+ license = GPL3
+ makedepends = ffnvcodec-headers
+ makedepends = git
+ makedepends = ladspa
+ makedepends = yasm
+ depends = alsa-lib
+ depends = aom
+ depends = bzip2
+ depends = fontconfig
+ depends = fribidi
+ depends = glibc
+ depends = gmp
+ depends = gnutls
+ depends = gsm
+ depends = jack
+ depends = lame
+ depends = libavc1394
+ depends = libdrm
+ depends = libiec61883
+ depends = libmodplug
+ depends = libomxil-bellagio
+ depends = libpulse
+ depends = libraw1394
+ depends = libsoxr
+ depends = libssh
+ depends = libtheora
+ depends = libvdpau
+ depends = libwebp
+ depends = libx11
+ depends = libxcb
+ depends = libxext
+ depends = libxml2
+ depends = libxv
+ depends = opencore-amr
+ depends = openjpeg2
+ depends = opus
+ depends = sdl2
+ depends = speex
+ depends = v4l-utils
+ depends = xz
+ depends = zlib
+ depends = libass.so
+ depends = libbluray.so
+ depends = libfreetype.so
+ depends = libva-drm.so
+ depends = libva.so
+ depends = libva-x11.so
+ depends = libvidstab.so
+ depends = libvorbisenc.so
+ depends = libvorbis.so
+ depends = libvpx.so
+ depends = libx264.so
+ depends = libx265.so
+ depends = libxvidcore.so
+ depends = tmblock-git
+ optdepends = ladspa: LADSPA filters
+ provides = libavcodec.so
+ provides = libavdevice.so
+ provides = libavfilter.so
+ provides = libavformat.so
+ provides = libavresample.so
+ provides = libavutil.so
+ provides = libpostproc.so
+ provides = libswresample.so
+ provides = libswscale.so
+ provides = ffmpeg
+ conflicts = ffmpeg
+ source = git+https://github.com/TMBlock/ffmpeg.git#branch=tmblock
+ sha256sums = SKIP
+
+pkgname = ffmpeg-tmblock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcc004c8dffa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,99 @@
+# Maintainer: Maxime Gauduin <huiyiqun@gmail.com>
+
+pkgname=ffmpeg-tmblock-git
+pkgver=r91177.970872f23a
+pkgrel=1
+epoch=1
+pkgdesc='Complete solution to record, convert and stream audio and video, with TMBlock support'
+arch=('x86_64')
+url='http://ffmpeg.org/'
+license=('GPL3')
+depends=(
+ 'alsa-lib' 'aom' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
+ 'jack' 'lame' 'libavc1394' 'libdrm' 'libiec61883' 'libmodplug'
+ 'libomxil-bellagio' 'libpulse' 'libraw1394' 'libsoxr' 'libssh' 'libtheora'
+ 'libvdpau' 'libwebp' 'libx11' 'libxcb' 'libxext' 'libxml2' 'libxv'
+ 'opencore-amr' 'openjpeg2' 'opus' 'sdl2' 'speex' 'v4l-utils' 'xz' 'zlib'
+ 'libass.so' 'libbluray.so' 'libfreetype.so' 'libva-drm.so' 'libva.so'
+ 'libva-x11.so' 'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so' 'libvpx.so'
+ 'libx264.so' 'libx265.so' 'libxvidcore.so' 'tmblock-git'
+)
+makedepends=('ffnvcodec-headers' 'git' 'ladspa' 'yasm')
+optdepends=('ladspa: LADSPA filters')
+provides=(
+ 'libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
+ 'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
+ 'libswscale.so' 'ffmpeg'
+)
+conflicts=('ffmpeg')
+source=("git+https://github.com/TMBlock/ffmpeg.git#branch=tmblock")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/ffmpeg"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd ffmpeg
+
+ ./configure \
+ --prefix='/usr' \
+ --disable-debug \
+ --disable-static \
+ --disable-stripping \
+ --enable-avresample \
+ --enable-fontconfig \
+ --enable-gmp \
+ --enable-gnutls \
+ --enable-gpl \
+ --enable-ladspa \
+ --enable-libaom \
+ --enable-libass \
+ --enable-libbluray \
+ --enable-libdrm \
+ --enable-libfreetype \
+ --enable-libfribidi \
+ --enable-libgsm \
+ --enable-libiec61883 \
+ --enable-libjack \
+ --enable-libmodplug \
+ --enable-libmp3lame \
+ --enable-libopencore_amrnb \
+ --enable-libopencore_amrwb \
+ --enable-libopenjpeg \
+ --enable-libopus \
+ --enable-libpulse \
+ --enable-libsoxr \
+ --enable-libspeex \
+ --enable-libssh \
+ --enable-libtheora \
+ --enable-libv4l2 \
+ --enable-libvidstab \
+ --enable-libvorbis \
+ --enable-libvpx \
+ --enable-libwebp \
+ --enable-libx264 \
+ --enable-libx265 \
+ --enable-libxcb \
+ --enable-libxml2 \
+ --enable-libxvid \
+ --enable-nvenc \
+ --enable-omx \
+ --enable-shared \
+ --enable-version3 \
+ --enable-tmblock
+
+
+ make
+ make tools/qt-faststart
+ make doc/ff{mpeg,play}.1
+}
+
+package() {
+ make DESTDIR="${pkgdir}" -C ffmpeg install install-man
+ install -Dm 755 ffmpeg/tools/qt-faststart "${pkgdir}"/usr/bin/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/fs56089.patch b/fs56089.patch
new file mode 100644
index 000000000000..6aca38f9f96c
--- /dev/null
+++ b/fs56089.patch
@@ -0,0 +1,84 @@
+diff -rupN ffmpeg-3.4.orig/libavformat/aviobuf.c ffmpeg-3.4/libavformat/aviobuf.c
+--- ffmpeg-3.4.orig/libavformat/aviobuf.c 2017-11-02 14:57:16.078834563 +0100
++++ ffmpeg-3.4/libavformat/aviobuf.c 2017-11-02 15:02:52.549816990 +0100
+@@ -531,6 +531,24 @@ void avio_write_marker(AVIOContext *s, i
+ s->last_time = time;
+ }
+
++static int read_packet_wrapper(AVIOContext *s, uint8_t *buf, int size)
++{
++ int ret;
++
++ if (!s->read_packet)
++ return AVERROR_EOF;
++ ret = s->read_packet(s->opaque, buf, size);
++#if FF_API_OLD_AVIO_EOF_0
++ if (!ret && !s->max_packet_size) {
++ av_log(NULL, AV_LOG_WARNING, "Invalid return value 0 for stream protocol\n");
++ ret = AVERROR_EOF;
++ }
++#else
++ av_assert2(ret || s->max_packet_size);
++#endif
++ return ret;
++}
++
+ /* Input stream */
+
+ static void fill_buffer(AVIOContext *s)
+@@ -569,10 +587,7 @@ static void fill_buffer(AVIOContext *s)
+ len = s->orig_buffer_size;
+ }
+
+- if (s->read_packet)
+- len = s->read_packet(s->opaque, dst, len);
+- else
+- len = 0;
++ len = read_packet_wrapper(s, dst, len);
+ if (len <= 0) {
+ /* do not modify buffer if EOF reached so that a seek back can
+ be done without rereading data */
+@@ -644,8 +659,7 @@ int avio_read(AVIOContext *s, unsigned c
+ if (len == 0 || s->write_flag) {
+ if((s->direct || size > s->buffer_size) && !s->update_checksum) {
+ // bypass the buffer and read data directly into buf
+- if(s->read_packet)
+- len = s->read_packet(s->opaque, buf, size);
++ len = read_packet_wrapper(s, buf, size);
+
+ if (len <= 0) {
+ /* do not modify buffer if EOF reached so that a seek back can
+@@ -711,7 +725,7 @@ int avio_read_partial(AVIOContext *s, un
+ return -1;
+
+ if (s->read_packet && s->write_flag) {
+- len = s->read_packet(s->opaque, buf, size);
++ len = read_packet_wrapper(s, buf, size);
+ if (len > 0)
+ s->pos += len;
+ return len;
+diff -rupN ffmpeg-3.4.orig/libavformat/avio.h ffmpeg-3.4/libavformat/avio.h
+--- ffmpeg-3.4.orig/libavformat/avio.h 2017-11-02 14:57:16.078834563 +0100
++++ ffmpeg-3.4/libavformat/avio.h 2017-11-02 14:59:15.602300896 +0100
+@@ -452,6 +452,8 @@ void avio_free_directory_entry(AVIODirEn
+ * @param write_flag Set to 1 if the buffer should be writable, 0 otherwise.
+ * @param opaque An opaque pointer to user-specific data.
+ * @param read_packet A function for refilling the buffer, may be NULL.
++ * For stream protocols, must never return 0 but rather
++ * a proper AVERROR code.
+ * @param write_packet A function for writing the buffer contents, may be NULL.
+ * The function may not change the input buffers content.
+ * @param seek A function for seeking to specified byte position, may be NULL.
+diff -rupN ffmpeg-3.4.orig/libavformat/version.h ffmpeg-3.4/libavformat/version.h
+--- ffmpeg-3.4.orig/libavformat/version.h 2017-11-02 14:57:16.082167807 +0100
++++ ffmpeg-3.4/libavformat/version.h 2017-11-02 15:04:01.704627612 +0100
+@@ -97,6 +97,9 @@
+ #ifndef FF_API_OLD_ROTATE_API
+ #define FF_API_OLD_ROTATE_API (LIBAVFORMAT_VERSION_MAJOR < 58)
+ #endif
++#ifndef FF_API_OLD_AVIO_EOF_0
++#define FF_API_OLD_AVIO_EOF_0 (LIBAVFORMAT_VERSION_MAJOR < 58)
++#endif
+
+
+ #ifndef FF_API_R_FRAME_RATE