summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimescam2020-02-27 14:26:10 +0800
committertimescam2020-02-27 14:26:10 +0800
commit7dbff148ce408a69188834876118419df8561355 (patch)
tree1b4b2917497a648b3eadd230f999fe9dc1c1d5e1
parent1fcee5fa4975711032fd2f62df1ead795380b468 (diff)
downloadaur-ffmpeg0.10.tar.gz
updated PKGBUILD to support x264 again, thanks to zombiemeat
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab610120c000..6d0a9b42f890 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg0.10
pkgdesc = Complete solution to record, convert and stream audio and video
pkgver = 0.10.16
- pkgrel = 4
+ pkgrel = 5
url = http://ffmpeg.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d9e4856bf56d..2fd5301a7999 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=ffmpeg0.10
pkgver=0.10.16
-pkgrel=4
+pkgrel=5
pkgdesc='Complete solution to record, convert and stream audio and video'
arch=('i686' 'x86_64')
url='http://ffmpeg.org/'
@@ -33,8 +33,8 @@ sha256sums=('e77823cbd58dfdb61f88059476070bc432d80e3821c14abcf804ef709d2f3fd1'
prepare() {
cd ffmpeg-${pkgver}
-
patch -Np1 -i ../ffmpeg-0.10-libvpx-1.5.patch
+ sed -i 's/x264_bit_depth/X264_BIT_DEPTH/' libavcodec/libx264.c
}
build() {
@@ -72,7 +72,8 @@ build() {
--enable-shared \
--enable-vdpau \
--enable-version3 \
- --enable-x11grab
+ --enable-x11grab \
+ --enable-libx264
make
}