summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 16:12:39 +0200
committersl1pkn072015-06-08 16:12:39 +0200
commita31ecae6879a0d2d921b59d0de70c0a5549bca47 (patch)
tree0b19219dfa46749b7bbd52d779ab5a79012bcb43
downloadaur-a31ecae6879a0d2d921b59d0de70c0a5549bca47.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba79fb264ede
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ffms2-git
+ pkgdesc = An FFmpeg/Libav based source library and Avisynth/Vapoursynth plugin for easy frame accurate access (GIT version)
+ pkgver = 2.21.11.g08838b2
+ pkgrel = 1
+ url = https://github.com/FFMS/ffms2
+ arch = x86_64
+ arch = i686
+ license = GPL
+ license = MIT
+ makedepends = git
+ depends = ffmpeg
+ provides = ffms2
+ provides = vapoursynth-plugin-ffms2-git
+ conflicts = ffms2
+ conflicts = vapoursynth-plugin-ffms2-git
+ replaces = ffmpegsource
+ source = git+https://github.com/FFMS/ffms2.git
+ sha1sums = SKIP
+
+pkgname = ffms2-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..543114a3938f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+#Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=ffms2-git
+pkgver=2.21.11.g08838b2
+pkgrel=1
+pkgdesc="An FFmpeg/Libav based source library and Avisynth/Vapoursynth plugin for easy frame accurate access (GIT version)"
+url="https://github.com/FFMS/ffms2"
+arch=('x86_64' 'i686')
+license=('GPL' 'MIT')
+depends=('ffmpeg')
+makedepends=('git')
+provides=('ffms2' 'vapoursynth-plugin-ffms2-git')
+conflicts=('ffms2' 'vapoursynth-plugin-ffms2-git')
+replaces=('ffmpegsource')
+source=('git+https://github.com/FFMS/ffms2.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd ffms2
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd ffms2
+ ./configure --prefix=/usr --enable-shared=yes --enable-static=no --enable-avresample
+ make
+}
+
+package() {
+ cd ffms2
+ make DESTDIR="${pkgdir}" install
+ install -d "${pkgdir}/usr/lib/vapoursynth"
+ ln -s ../libffms2.so "${pkgdir}/usr/lib/vapoursynth/"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+}