summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-09-20 20:36:52 +0200
committersL1pKn072018-09-20 20:36:52 +0200
commitaf902950b798868bb47af361e879aee159f142f6 (patch)
treee0a6647ac1ae0935c64070ce4f97bd2cedc686bf
parent0dd881b5fa2a483c90edb1f138d7e8194b50e52a (diff)
downloadaur-af902950b798868bb47af361e879aee159f142f6.tar.gz
--libavresample.so
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3c4e5b84f24..4eef1a1d4a21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Thu Jan 4 18:06:26 UTC 2018
+# Thu Sep 20 18:36:19 UTC 2018
pkgbase = ffms2-git
pkgdesc = An FFmpeg/Libav based source library and Avisynth/Vapoursynth plugin for easy frame accurate access. (GIT version)
- pkgver = 2.23.153.g722a02d
+ pkgver = 2.23.187.gc3fc445
pkgrel = 1
url = https://github.com/FFMS/ffms2
- arch = i686
arch = x86_64
license = GPL
makedepends = git
@@ -14,9 +13,8 @@ pkgbase = ffms2-git
depends = libavcodec.so
depends = libswscale.so
depends = libavutil.so
- depends = libavresample.so
- provides = libffms2.so
provides = ffms2
+ provides = libffms2.so
provides = vapoursynth-plugin-ffms2
conflicts = ffms2
source = git+https://github.com/FFMS/ffms2.git
diff --git a/PKGBUILD b/PKGBUILD
index b6af7e131629..79887f492212 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=ffms2-git
-pkgver=2.23.153.g722a02d
+pkgver=2.23.187.gc3fc445
pkgrel=1
pkgdesc="An FFmpeg/Libav based source library and Avisynth/Vapoursynth plugin for easy frame accurate access. (GIT version)"
url='https://github.com/FFMS/ffms2'
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL')
depends=('gcc-libs'
'libavformat.so'
'libavcodec.so'
'libswscale.so'
'libavutil.so'
- 'libavresample.so'
)
makedepends=('git')
-provides=('libffms2.so'
- 'ffms2'
+provides=('ffms2'
+ 'libffms2.so'
'vapoursynth-plugin-ffms2'
)
conflicts=('ffms2')
@@ -29,23 +28,24 @@ pkgver() {
}
prepare() {
- cd ffms2
- sh ./autogen.sh
-}
+ mkdir -p build
-build() {
- cd ffms2
- ./configure \
+ (cd ffms2; mkdir -p src/config; autoreconf -vfi)
+
+ cd build
+ ../ffms2/configure \
--prefix=/usr \
--enable-shared=yes \
--enable-static=no
- make
+}
+
+build() {
+ make -C build
}
package() {
- cd ffms2
- make DESTDIR="${pkgdir}" install
+ make -C build DESTDIR="${pkgdir}" install
install -d "${pkgdir}/usr/lib/vapoursynth"
ln -s /usr/lib/libffms2.so "${pkgdir}/usr/lib/vapoursynth/"
}