summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-11-28 02:31:34 +0100
committersl1pkn072015-11-28 02:31:34 +0100
commitc3c1e0c33fb45fd29a87c052b10c297a2187b552 (patch)
tree5bf7921400d5b945d4f05d0d04ff6b2242f6d61b
parent7ad53c3f203083bca2205a715909a06efa933cb8 (diff)
downloadaur-c3c1e0c33fb45fd29a87c052b10c297a2187b552.tar.gz
Update depends=()
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f38cafb4b2da..274d63406f99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,19 @@
pkgbase = ffms2-git
pkgdesc = An FFmpeg/Libav based source library and Avisynth/Vapoursynth plugin for easy frame accurate access. (GIT version)
- pkgver = 2.21.33.gc1dc5ad
+ pkgver = 2.22.0.g129952a
pkgrel = 1
url = https://github.com/FFMS/ffms2
- arch = x86_64
arch = i686
+ arch = x86_64
license = GPL
makedepends = git
- depends = ffmpeg
+ depends = gcc-libs
+ depends = libavformat.so
+ depends = libavcodec.so
+ depends = libswscale.so
+ depends = libavutil.so
+ depends = libavresample.so
+ provides = libffms2.so
provides = ffms2
provides = vapoursynth-plugin-ffms2
conflicts = ffms2
diff --git a/PKGBUILD b/PKGBUILD
index 8cee52a7a1ec..2f9e11ab51e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,24 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=ffms2-git
-pkgver=2.21.33.gc1dc5ad
+pkgver=2.22.0.g129952a
pkgrel=1
pkgdesc="An FFmpeg/Libav based source library and Avisynth/Vapoursynth plugin for easy frame accurate access. (GIT version)"
url='https://github.com/FFMS/ffms2'
-arch=('x86_64' 'i686')
+arch=('i686' 'x86_64')
license=('GPL')
-depends=('ffmpeg')
+depends=('gcc-libs'
+ 'libavformat.so'
+ 'libavcodec.so'
+ 'libswscale.so'
+ 'libavutil.so'
+ 'libavresample.so'
+ )
makedepends=('git')
-provides=('ffms2' 'vapoursynth-plugin-ffms2')
+provides=('libffms2.so'
+ 'ffms2'
+ 'vapoursynth-plugin-ffms2'
+ )
conflicts=('ffms2')
source=('git+https://github.com/FFMS/ffms2.git')
sha1sums=('SKIP')
@@ -32,5 +41,5 @@ package() {
cd ffms2
make DESTDIR="${pkgdir}" install
install -d "${pkgdir}/usr/lib/vapoursynth"
- ln -s ../libffms2.so "${pkgdir}/usr/lib/vapoursynth/"
+ ln -s /usr/lib/libffms2.so "${pkgdir}/usr/lib/vapoursynth/"
}