summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-10-24 03:46:57 +0200
committersL1pKn072020-10-24 03:46:57 +0200
commiteb4f57b24cf909d8b052541aad72d5a34ef11d32 (patch)
treeaf896e5fec5ea4a0f406176c4b763b5695584873
parentb249e267df4d25e891c5c89202565e3fd35a376f (diff)
downloadaur-eb4f57b24cf909d8b052541aad72d5a34ef11d32.tar.gz
bump
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD33
-rw-r--r--esee.patch33
4 files changed, 67 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c32da94427b4..a6e391c3e84b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,28 @@
pkgbase = ffms2-git
pkgdesc = An FFmpeg/Libav based source library and Avisynth/Vapoursynth plugin for easy frame accurate access. (GIT version)
- pkgver = 2.23.203.gbda9eeb
- pkgrel = 3
+ pkgver = 2.40.0.g55c2af5
+ pkgrel = 1
url = https://github.com/FFMS/ffms2
arch = x86_64
license = GPL
makedepends = git
+ makedepends = vapoursynth
+ makedepends = avisynthplus
depends = gcc-libs
depends = libavformat.so
depends = libavcodec.so
depends = libswscale.so
depends = libavutil.so
+ optdepends = vapoursynth: Vapoursynth support
+ optdepends = avisynth: Avisynth support
provides = ffms2
provides = libffms2.so
provides = vapoursynth-plugin-ffms2
provides = vapoursynth-plugin-ffms2-git
conflicts = ffms2
source = git+https://github.com/FFMS/ffms2.git
+ source = esee.patch
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = ffms2-git
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..300a542d8569 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!.SRCINFO
!PKGBUILD
+!esee.patch
diff --git a/PKGBUILD b/PKGBUILD
index 51058911171a..ace6999267f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=ffms2-git
-pkgver=2.23.203.gbda9eeb
-pkgrel=3
+pkgver=2.40.0.g55c2af5
+pkgrel=1
pkgdesc="An FFmpeg/Libav based source library and Avisynth/Vapoursynth plugin for easy frame accurate access. (GIT version)"
url='https://github.com/FFMS/ffms2'
arch=('x86_64')
@@ -13,15 +13,25 @@ depends=('gcc-libs'
'libswscale.so'
'libavutil.so'
)
-makedepends=('git')
+makedepends=('git'
+ 'vapoursynth'
+ 'avisynthplus'
+ )
provides=('ffms2'
'libffms2.so'
'vapoursynth-plugin-ffms2'
'vapoursynth-plugin-ffms2-git'
)
conflicts=('ffms2')
-source=('git+https://github.com/FFMS/ffms2.git')
-sha256sums=('SKIP')
+optdepends=('vapoursynth: Vapoursynth support'
+ 'avisynth: Avisynth support'
+ )
+source=('git+https://github.com/FFMS/ffms2.git'
+ 'esee.patch'
+ )
+sha256sums=('SKIP'
+ 'SKIP'
+ )
pkgver() {
cd ffms2
@@ -33,6 +43,10 @@ prepare() {
cd ffms2
+ # use pkg-config for search Avisyhth/Vapoursynth
+ rm -fr src/vapoursynth/{Vapoursynth,VSHelper}.h
+ patch -p1 -i "${srcdir}/esee.patch"
+
mkdir -p src/config
}
@@ -45,14 +59,17 @@ build() {
../ffms2/configure \
--prefix=/usr \
--enable-shared=yes \
- --enable-static=no
+ --enable-static=no \
+ --enable-avisynth
make
}
package() {
make -C build DESTDIR="${pkgdir}" install
- install -d "${pkgdir}/usr/lib/vapoursynth"
+ install -d "${pkgdir}/usr/lib/"{avi,vapour}synth
ln -s /usr/lib/libffms2.so "${pkgdir}/usr/lib/vapoursynth/"
- install -Dm644 ffms2/doc/ffms2-vapoursynth.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/ffms2-vapoursynth.md"
+ ln -s /usr/lib/libffms2.so "${pkgdir}/usr/lib/avisynth/"
+ install -Dm644 ffms2/doc/ffms2-vapoursynth.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/ffms2/ffms2-vapoursynth.md"
+ install -Dm644 ffms2/doc/ffms2-avisynth.md "${pkgdir}/usr/share/doc/avisynth/plugins/ffms2/ffms2-vapoursynth.md"
}
diff --git a/esee.patch b/esee.patch
new file mode 100644
index 000000000000..c1d80ac557d2
--- /dev/null
+++ b/esee.patch
@@ -0,0 +1,33 @@
+diff --git a/Makefile.am b/Makefile.am
+index 61d9921..0559c0a 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -15,6 +15,8 @@ AM_CPPFLAGS = \
+ -D__STDC_CONSTANT_MACROS \
+ @FFMPEG_CFLAGS@ \
+ @ZLIB_CPPFLAGS@ \
++ @Avisynth_CFLAGS@ \
++ @Vapoursynth_CFLAGS@ \
+ -include config.h
+ AM_CXXFLAGS = -std=c++11 -fvisibility=hidden
+
+diff --git a/configure.ac b/configure.ac
+index b35ef80..5c3796a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -118,6 +118,15 @@ if test "$FFMPEG_WORKS" = no; then
+ AC_MSG_FAILURE([cannot link with FFmpeg])
+ fi
+
++if test "$enable_avisynth" = "yes"; then
++PKG_CHECK_MODULES(Avisynth, [avisynth])
++AC_SUBST([Avisynth_CFLAGS])
++fi
++
++#Let's hack vapoursynth!
++PKG_CHECK_MODULES(Vapoursynth, [vapoursynth])
++AC_SUBST([Vapoursynth_CFLAGS])
++
+ src_core_libffms2_la_LDFLAGS=""
+ AC_MSG_CHECKING([whether -Wl,-Bsymbolic is needed])
+ if test "$enable_shared" = yes; then