summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-07-09 19:14:44 +0200
committersL1pKn072017-07-09 19:14:44 +0200
commit4050e5c47edc3ff7f0d03c85a84cb7fe9120e1b1 (patch)
tree03f9eabd2971c4fd6433260ef4fd5dd2e456c838
downloadaur-4050e5c47edc3ff7f0d03c85a84cb7fe9120e1b1.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abe44bcb60d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Sun Jul 9 17:14:44 UTC 2017
+pkgbase = ffms2000-git
+ pkgdesc = The experimental future of FFMS2. (GIT version)
+ pkgver = 2.22.172.g68895b7
+ pkgrel = 1
+ url = https://forum.doom9.org/showthread.php?t=174469
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = gcc-libs
+ depends = libavformat.so
+ depends = libavcodec.so
+ depends = libswscale.so
+ depends = libavutil.so
+ depends = libavresample.so
+ provides = libffms2.so
+ provides = ffms2
+ provides = vapoursynth-plugin-ffms2
+ conflicts = ffms2
+ source = git+https://github.com/FFMS/ffms2.git#branch=ffms2000
+ sha256sums = SKIP
+
+pkgname = ffms2000-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78243eba09e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=ffms2000-git
+pkgver=2.22.172.g68895b7
+pkgrel=1
+pkgdesc="The experimental future of FFMS2. (GIT version)"
+url='https://forum.doom9.org/showthread.php?t=174469'
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('gcc-libs'
+ 'libavformat.so'
+ 'libavcodec.so'
+ 'libswscale.so'
+ 'libavutil.so'
+ 'libavresample.so'
+ )
+makedepends=('git')
+provides=('libffms2.so'
+ 'ffms2'
+ 'vapoursynth-plugin-ffms2'
+ )
+conflicts=('ffms2')
+source=('git+https://github.com/FFMS/ffms2.git#branch=ffms2000')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ffms2
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd ffms2
+ ./autogen.sh \
+ --prefix=/usr \
+ --enable-shared=yes \
+ --enable-static=no
+
+ make
+}
+
+package() {
+ cd ffms2
+ make DESTDIR="${pkgdir}" install
+ install -d "${pkgdir}/usr/lib/vapoursynth"
+ ln -s /usr/lib/libffms2.so "${pkgdir}/usr/lib/vapoursynth/"
+}