summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlias Stamatis2015-06-08 16:30:07 +0300
committerIlias Stamatis2015-06-08 16:30:07 +0300
commit60c1760ace0da33f414ee1b1c37e7442a0f09315 (patch)
tree64f098df9a1121c683c83ba3c9de5737000db003
downloadaur-60c1760ace0da33f414ee1b1c37e7442a0f09315.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b57ccc52f819
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ffmulticonverter-git
+ pkgdesc = Convert audio, video, image and document files between all popular formats
+ pkgver = 1.7.0.r6.g97c6ae3
+ pkgrel = 1
+ url = https://sites.google.com/site/ffmulticonverter/
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python-pyqt4
+ optdepends = ffmpeg: for video conversions
+ optdepends = imagemagick: for image conversions
+ optdepends = unoconv: for document conversions
+ conflicts = ffmulticonverter
+ source = ffmulticonverter-git::git+https://github.com/Ilias95/FF-Multi-Converter.git
+ sha256sums = SKIP
+
+pkgname = ffmulticonverter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cab19a6d8914
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ilias Stamatis <stamatis.iliass at gmail dot com>
+# Contributor: Panagiotis Mavrogiorgos (pmav99) <> (gmail)
+
+pkgname=ffmulticonverter-git
+pkgver=1.7.0.r6.g97c6ae3
+pkgrel=1
+pkgdesc="Convert audio, video, image and document files between all popular formats"
+arch=(any)
+url="https://sites.google.com/site/ffmulticonverter/"
+license=('GPL3')
+depends=('python-pyqt4')
+optdepends=('ffmpeg: for video conversions'
+ 'imagemagick: for image conversions'
+ 'unoconv: for document conversions')
+makedepends=('git')
+conflicts=('ffmulticonverter')
+source=("${pkgname}::git+https://github.com/Ilias95/FF-Multi-Converter.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}