summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquagsirus2023-06-29 22:41:17 +0100
committerquagsirus2023-06-29 22:41:17 +0100
commit563721361af367db9ced22bac43b948a9e4b26f9 (patch)
treee5e6fa869c6edd1541f389f1516961a984014812
downloadaur-563721361af367db9ced22bac43b948a9e4b26f9.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3cbc57a28d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ffnvcodec-headers-11-1
+ pkgdesc = FFmpeg version of headers required to interface with Nvidias codec APIs (Version 11.1 for driver 470.xx support)
+ pkgver = 11.1.5.2
+ pkgrel = 1
+ url = https://git.videolan.org/?p=ffmpeg/nv-codec-headers.git
+ arch = any
+ license = MIT
+ makedepends = git
+ provides = ffnvcodec-headers
+ conflicts = ffnvcodec-headers
+ source = git+https://git.videolan.org/git/ffmpeg/nv-codec-headers.git#tag=f8ae7a49bfef2f99d2c931a791dc3863fda67bf3
+ sha256sums = SKIP
+
+pkgname = ffnvcodec-headers-11-1
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b745ac9e889c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer : quagsirus <quagsirus at catpowered dot net>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Daniel Bermond <danielbermond@yahoo.com>
+
+pkgname=ffnvcodec-headers-11-1
+pkgver=11.1.5.2
+pkgrel=1
+pkgdesc='FFmpeg version of headers required to interface with Nvidias codec APIs (Version 11.1 for driver 470.xx support)'
+provides=('ffnvcodec-headers')
+conflicts=('ffnvcodec-headers')
+arch=(any)
+url=https://git.videolan.org/?p=ffmpeg/nv-codec-headers.git
+license=(MIT)
+makedepends=(git)
+_tag=f8ae7a49bfef2f99d2c931a791dc3863fda67bf3
+source=(git+https://git.videolan.org/git/ffmpeg/nv-codec-headers.git#tag=${_tag})
+sha256sums=(SKIP)
+
+pkgver() {
+ cd nv-codec-headers
+
+ git describe --tags | sed 's/^n//'
+}
+
+build() {
+ make PREFIX=/usr -C nv-codec-headers
+ sed -n '4,25p' nv-codec-headers/include/ffnvcodec/nvEncodeAPI.h > LICENSE # Extract license
+ sed -i '1,22s/^.\{,3\}//' LICENSE # Delete C comments
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="${pkgdir}" -C nv-codec-headers install
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/ffnvcodec-headers/
+}
+
+# vim: ts=2 sw=2 et: