summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-02-27 15:53:13 -0300
committerDaniel Bermond2018-02-27 15:53:13 -0300
commitdcf4a41c57d648699f6fda46b3fddea98bcddac7 (patch)
tree0bc984e0da530ba5fca6ba514afadae1707bfe52
downloadaur-dcf4a41c57d648699f6fda46b3fddea98bcddac7.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a373ce19f6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ffnvcodec-headers-git
+ pkgdesc = FFmpeg version of headers required to interface with Nvidias codec APIs (git version)
+ pkgver = 8.0.14.1.r0.g12712ab
+ pkgrel = 1
+ url = https://git.videolan.org/?p=ffmpeg/nv-codec-headers.git
+ arch = any
+ license = MIT
+ makedepends = git
+ provides = ffnvcodec-headers
+ conflicts = ffnvcodec-headers
+ source = ffnvcodec-headers-git::git+https://git.videolan.org/git/ffmpeg/nv-codec-headers.git
+ sha256sums = SKIP
+
+pkgname = ffnvcodec-headers-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b10ad153b1b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
+
+pkgname=ffnvcodec-headers-git
+pkgver=8.0.14.1.r0.g12712ab
+pkgrel=1
+pkgdesc='FFmpeg version of headers required to interface with Nvidias codec APIs (git version)'
+arch=('any')
+url='https://git.videolan.org/?p=ffmpeg/nv-codec-headers.git'
+license=('MIT')
+makedepends=('git')
+provides=('ffnvcodec-headers')
+conflicts=('ffnvcodec-headers')
+source=("$pkgname"::'git+https://git.videolan.org/git/ffmpeg/nv-codec-headers.git')
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ sed -i 's|/usr/local|/usr|g' Makefile
+}
+
+pkgver() {
+ cd "$pkgname"
+
+ # git, tags available
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^[nv]//'
+}
+
+build() {
+ cd "$pkgname"
+ make # using PREFIX='/usr' seems not to work
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+
+ # license
+ sed -n '4,25p' include/ffnvcodec/nvEncodeAPI.h > LICENSE # create file
+ sed -i '1,22s/^.\{,3\}//' LICENSE # erase C comments
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}