summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimvisee2019-04-04 09:57:35 +0000
committertimvisee2019-04-04 09:57:35 +0000
commit5c0b79d32b3f6fa9266021e2fc964b9753985033 (patch)
treee3b2ea5076b4c84bac53ce85da4e07cec654d392
parentb8b0a6e3c012ec2df84ebf4090497a532115c264 (diff)
downloadaur-5c0b79d32b3f6fa9266021e2fc964b9753985033.tar.gz
Release v0.2.43
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2da30e634b9..8f8c07225350 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffsend
pkgdesc = Easily and securely share files from the command line. A Firefox Send client.
- pkgver = 0.2.42
+ pkgver = 0.2.43
pkgrel = 1
url = https://gitlab.com/timvisee/ffsend
arch = x86_64
@@ -12,9 +12,10 @@ pkgbase = ffsend
makedepends = cmake
depends = ca-certificates
optdepends = xclip: clipboard support
+ optdepends = bash-completion: support auto completion for bash
provides = ffsend
- source = ffsend-v0.2.42.tar.gz::https://gitlab.com/timvisee/ffsend/-/archive/v0.2.42/ffsend-v0.2.42.tar.gz
- sha256sums = 59e42d03f4e7a1092ce7b5bbaebd57d9810671cefa8805f027bf2b7d62f4e1fc
+ source = ffsend-v0.2.43.tar.gz::https://gitlab.com/timvisee/ffsend/-/archive/v0.2.43/ffsend-v0.2.43.tar.gz
+ sha256sums = 1b375690b7123ac90a3f6f5173410fcbacbfd8b4819fd1c56e8f1f2fee98c2fb
pkgname = ffsend
diff --git a/PKGBUILD b/PKGBUILD
index 8edc13334379..435c3f41c088 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,19 @@
# - Mirror: https://github.com/timvisee/ffsend/blob/master/pkg/aur/ffsend/PKGBUILD
pkgname=ffsend
-pkgver=0.2.42
+pkgver=0.2.43
pkgrel=1
pkgdesc="Easily and securely share files from the command line. A Firefox Send client."
url="https://gitlab.com/timvisee/ffsend"
license=('GPL3')
-source=("ffsend-v$pkgver.tar.gz::https://gitlab.com/timvisee/ffsend/-/archive/v0.2.42/ffsend-v0.2.42.tar.gz")
-sha256sums=('59e42d03f4e7a1092ce7b5bbaebd57d9810671cefa8805f027bf2b7d62f4e1fc')
+source=("ffsend-v$pkgver.tar.gz::https://gitlab.com/timvisee/ffsend/-/archive/v0.2.43/ffsend-v0.2.43.tar.gz")
+sha256sums=('1b375690b7123ac90a3f6f5173410fcbacbfd8b4819fd1c56e8f1f2fee98c2fb')
arch=('x86_64' 'i686')
provides=('ffsend')
depends=('ca-certificates')
makedepends=('openssl>=1.0' 'rust>=1.32' 'cargo' 'cmake')
-optdepends=('xclip: clipboard support')
+optdepends=('xclip: clipboard support'
+ 'bash-completion: support auto completion for bash')
build() {
cd "ffsend-v$pkgver"
@@ -24,5 +25,13 @@ build() {
}
package() {
- install -Dm755 "$srcdir/ffsend-v$pkgver/target/release/ffsend" "$pkgdir/usr/bin/ffsend"
+ cd "$srcdir/ffsend-v$pkgver"
+
+ # Install Binary
+ install -Dm755 "./target/release/ffsend" "$pkgdir/usr/bin/ffsend"
+
+ # Install completions
+ cd "./contrib/completions"
+ install -Dm644 "ffsend.bash" "$pkgver/usr/share/bash-completion/completions/ffsend"
+ install -Dm644 "ffsend.fish" "$pkgver/usr/share/fish/vendor_completions.d/ffsend.fish"
}