summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimvisee2019-01-12 22:10:14 +0000
committertimvisee2019-01-12 22:10:14 +0000
commit618fabb4247a50b4198e57831be2a4e4c11a4645 (patch)
tree8155beb09fb6da070d84eed8ccc6ea9e1c0379e8
downloadaur-618fabb4247a50b4198e57831be2a4e4c11a4645.tar.gz
Release v0.1.1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec6cd758e015
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ffsend
+ pkgdesc = Easily and securely share files from the command line. A Firefox Send client.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://gitlab.com/timvisee/ffsend
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = openssl>=1.0
+ makedepends = rust
+ makedepends = cargo
+ makedepends = cmake
+ depends = ca-certificates
+ optdepends = xclip: clipboard support
+ source = ffsend-v0.1.1.tar.gz::https://gitlab.com/timvisee/ffsend/-/archive/v0.1.1/ffsend-v0.1.1.tar.gz
+ sha256sums = SKIP
+
+pkgname = ffsend
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e219e6f69674
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Tim Visee <timvisee@gmail.com>
+
+pkgname=ffsend
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Easily and securely share files from the command line. A Firefox Send client."
+url="https://gitlab.com/timvisee/ffsend"
+license=('GPL3')
+source=("$pkgname-v$pkgver.tar.gz::$url/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+sha256sums=('SKIP')
+arch=('x86_64' 'i686')
+depends=('ca-certificates')
+makedepends=('openssl>=1.0' 'rust' 'cargo' 'cmake')
+optdepends=('xclip: clipboard support')
+
+pkgver() {
+ cd "$pkgname-v$pkgver"
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2)"
+ #.$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$pkgname-v$pkgver"
+ env CARGO_INCREMENTAL=0 cargo build --release
+}
+
+package() {
+ install -Dm755 "$srcdir/$pkgname-v$pkgver/target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}