summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraxionl2019-03-25 17:35:09 +0900
committeraxionl2019-03-25 17:35:09 +0900
commit7885bdbd0d30c62b55d4b0434d8808f49ce04903 (patch)
tree36c26258f84f403a80955693fdca740e17c3abf8
downloadaur-7885bdbd0d30c62b55d4b0434d8808f49ce04903.tar.gz
[AddPkg] ffsend-bin: Easily and securely share files from the command line. A fully featured Firefox Send client.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f485ed64311f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ffsend-bin
+ pkgdesc = Easily and securely share files from the command line. A Firefox Send client.
+ pkgver = 0.2.39
+ pkgrel = 1
+ url = https://gitlab.com/timvisee/ffsend
+ arch = x86_64
+ license = GPL3
+ depends = ca-certificates
+ optdepends = xclip: clipboard support
+ provides = ffsend
+ conflicts = ffsend-git
+ conflicts = ffsend
+ source = ffsend::https://github.com/timvisee/ffsend/releases/download/v0.2.39/ffsend-v0.2.39-linux-x64-static
+ sha256sums = 920887f505925963a40388e1a8553eb5cca7ee59c03dc285eb541ab0f02c7da0
+
+pkgname = ffsend-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b383c72c21b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Tim Visee <tim@visee.me>
+# Contributor: Ariel AxionL <i at axionl dot me>
+
+pkgname=ffsend-bin
+pkgver=0.2.39
+pkgrel=1
+pkgdesc="Easily and securely share files from the command line. A Firefox Send client."
+url="https://gitlab.com/timvisee/ffsend"
+license=('GPL3')
+provides=('ffsend')
+conflicts=('ffsend-git' 'ffsend')
+source=("ffsend::https://github.com/timvisee/ffsend/releases/download/v$pkgver/ffsend-v$pkgver-linux-x64-static")
+sha256sums=('920887f505925963a40388e1a8553eb5cca7ee59c03dc285eb541ab0f02c7da0')
+arch=('x86_64')
+depends=('ca-certificates')
+optdepends=('xclip: clipboard support')
+
+package() {
+ install -Dm755 "${srcdir}/ffsend" "${pkgdir}/usr/bin/ffsend"
+}