summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimvisee2019-04-04 09:57:50 +0000
committertimvisee2019-04-04 09:57:50 +0000
commit0fe040f584e7096bf1ad7011938877a9b5f63548 (patch)
treeeafefbc9790fd0d86a0d361f02f7dd2c7b3bccbb
parenta75bab7d17a15a5042f363f356dbd1401b3cdff8 (diff)
downloadaur-0fe040f584e7096bf1ad7011938877a9b5f63548.tar.gz
Update PKGBUILD for release v0.2.43
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f17c13987561..f73162277d7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ffsend-git
pkgdesc = Easily and securely share files from the command line. A Firefox Send client.
- pkgver = 0.2.42.903c0312
+ pkgver = 0.2.43.2545708f
pkgrel = 1
url = https://gitlab.com/timvisee/ffsend
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = ffsend-git
makedepends = cmake
depends = ca-certificates
optdepends = xclip: clipboard support
+ optdepends = bash-completion: support auto completion for bash
provides = ffsend
conflicts = ffsend
source = ffsend::git+https://gitlab.com/timvisee/ffsend.git
diff --git a/PKGBUILD b/PKGBUILD
index 8f23c41c02d4..3ff8d0eac319 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# - Mirror: https://github.com/timvisee/ffsend/blob/master/pkg/aur/ffsend-git/PKGBUILD
pkgname=ffsend-git
-pkgver=0.2.42.903c0312
+pkgver=0.2.43.2545708f
pkgrel=1
pkgdesc="Easily and securely share files from the command line. A Firefox Send client."
url="https://gitlab.com/timvisee/ffsend"
@@ -17,7 +17,8 @@ provides=('ffsend')
conflicts=('ffsend')
depends=('ca-certificates')
makedepends=('openssl>=1.0' 'rust>=1.32' 'cargo' 'cmake')
-optdepends=('xclip: clipboard support')
+optdepends=('xclip: clipboard support'
+ 'bash-completion: support auto completion for bash')
build() {
cd ffsend
@@ -25,5 +26,13 @@ build() {
}
package() {
- install -Dm755 "$srcdir/ffsend/target/release/ffsend" "$pkgdir/usr/bin/ffsend"
+ cd "$srcdir/ffsend"
+
+ # Install Binary
+ install -Dm755 "./target/release/ffsend" "$pkgdir/usr/bin/ffsend"
+
+ # Install completions
+ cd "./contrib/completions"
+ install -Dm644 "ffsend.bash" "$pkgver/usr/share/bash-completion/completions/ffsend"
+ install -Dm644 "ffsend.fish" "$pkgver/usr/share/fish/vendor_completions.d/ffsend.fish"
}