summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimvisee2021-10-07 12:34:43 +0000
committertimvisee2021-10-07 12:34:43 +0000
commitc7d741042ad1b20a7bda206d1baa6cd7d154785e (patch)
tree4472500f8fe332f35257e513c9d4f2ef7e936f85
parent8ee1cacdb77169ed3261651021b23f8a810d0e6f (diff)
downloadaur-c7d741042ad1b20a7bda206d1baa6cd7d154785e.tar.gz
Update PKGBUILD for release v0.2.74
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD36
2 files changed, 28 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04796858d3fb..ffcc737ab015 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
pkgbase = ffsend-git
pkgdesc = Easily and securely share files from the command line. A Send client.
- pkgver = 0.2.72.e440f4b6
+ pkgver = 0.2.74.ccd489ce
pkgrel = 1
url = https://gitlab.com/timvisee/ffsend
arch = x86_64
arch = i686
license = GPL3
- makedepends = openssl>=1.0
- makedepends = rust>=1.39
makedepends = cargo
makedepends = cmake
+ makedepends = openssl>=1.0
depends = ca-certificates
optdepends = xclip: clipboard support
- optdepends = bash-completion: support auto completion for bash
provides = ffsend
conflicts = ffsend
- source = ffsend::git+https://gitlab.com/timvisee/ffsend.git
+ source = git+https://gitlab.com/timvisee/ffsend
sha256sums = SKIP
pkgname = ffsend-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 10d7e471ae68..9631fcd5620a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,47 @@
# - Mirror: https://github.com/timvisee/ffsend/blob/master/pkg/aur/ffsend-git/PKGBUILD
pkgname=ffsend-git
-pkgver=0.2.72.e440f4b6
+pkgver=0.2.74.ccd489ce
pkgrel=1
pkgdesc="Easily and securely share files from the command line. A Send client."
url="https://gitlab.com/timvisee/ffsend"
license=('GPL3')
-source=("ffsend::git+$url.git")
+source=("git+${url}")
sha256sums=('SKIP')
arch=('x86_64' 'i686')
provides=('ffsend')
conflicts=('ffsend')
depends=('ca-certificates')
-makedepends=('openssl>=1.0' 'rust>=1.39' 'cargo' 'cmake')
-optdepends=('xclip: clipboard support'
- 'bash-completion: support auto completion for bash')
+makedepends=('cargo' 'cmake' 'openssl>=1.0')
+optdepends=('xclip: clipboard support')
+
+prepare() {
+ cd "${pkgname%-git}"
+
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
build() {
- cd ffsend
- env CARGO_INCREMENTAL=0 cargo build --release
+ cd "${pkgname%-git}"
+
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+check() {
+ cd "${pkgname%-git}"
+
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen
}
package() {
- cd "$srcdir/ffsend"
+ cd "${pkgname%-git}"
- # Install Binary
- install -Dm755 "./target/release/ffsend" "$pkgdir/usr/bin/ffsend"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/ffsend"
- # Install shell completions and LICENSE file
+ # Shell completions and LICENSE file
install -Dm644 "contrib/completions/ffsend.bash" \
"$pkgdir/etc/bash_completion.d/ffsend"
install -Dm644 "contrib/completions/_ffsend" \