summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2022-04-17 01:19:12 +0100
committerJoão Figueiredo2022-04-17 01:19:12 +0100
commit0bad91ec98b52c10721bc0280397654032ca0940 (patch)
tree85a8629ff5a8cfdb72aa929ec1fd47a7ffb624fe
downloadaur-0bad91ec98b52c10721bc0280397654032ca0940.tar.gz
First commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b10cb71bfcdf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = fftool-git
+ pkgdesc = Tool to build force field input files for molecular simulation
+ pkgver = r175.0bf8a80
+ pkgrel = 1
+ url = https://github.com/paduagroup/fftool
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ optdepends = packmol: to pack molecules and materials in the simulation box
+ source = git+https://github.com/paduagroup/fftool.git
+ sha256sums = SKIP
+
+pkgname = fftool-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..484c8821571f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: João Figueiredo <islandc0der@chaotic.cx>
+
+pkgname=fftool-git
+pkgver=r175.0bf8a80
+pkgrel=1
+pkgdesc='Tool to build force field input files for molecular simulation'
+arch=(any)
+url='https://github.com/paduagroup/fftool'
+license=(MIT)
+depends=(python)
+optdepends=("packmol: to pack molecules and materials in the simulation box")
+makedepends=(git)
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${pkgname%-git}
+ install -Dm755 fftool lattice xyztool -t "$pkgdir/usr/bin/"
+ install -Dm644 examples/* -t "$pkgdir/usr/share/${pkgname%-git}/examples/"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}