summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Engmark2018-01-31 11:10:47 +1300
committerVictor Engmark2018-01-31 14:17:38 +1300
commitb837e8f85015dc5b251e5e4228ffb6dbf6dd4a13 (patch)
tree9e8792579af16fc0a947d43024927dce8d6a79e5
downloadaur-b837e8f85015dc5b251e5e4228ffb6dbf6dd4a13.tar.gz
Add build script
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD41
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..232e0b21d253
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = fgit-git
+ pkgdesc = Folder Git
+ pkgver = r86.44b62b2
+ pkgrel = 1
+ url = https://github.com/l0b0/fgit
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ depends = bash
+ depends = git
+ depends = ncurses
+ provides = fgit
+ conflicts = fgit
+ source = git+https://github.com/l0b0/fgit.git
+ source = git+https://github.com/l0b0/make-includes.git
+ source = git+https://github.com/l0b0/shell-includes.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = fgit-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c09c55974e16
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+fgit/
+*.pkg.tar.xz
+.idea/
+make-includes/
+pkg/
+shell-includes/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3803d755a59b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Victor Engmark <victor.engmark@gmail.com>
+pkgname=fgit-git
+pkgver=r87.342b35d
+pkgrel=1
+pkgdesc="Folder Git"
+arch=('any')
+url='https://github.com/l0b0/fgit'
+license=('GPL3')
+depends=('bash' 'git' 'ncurses')
+makedepends=('git' 'make')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(
+ 'git+https://github.com/l0b0/fgit.git'
+ 'git+https://github.com/l0b0/make-includes.git'
+ 'git+https://github.com/l0b0/shell-includes.git'
+)
+md5sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+ git config submodule.mysubmodule.url $srcdir/make-includes
+ git config submodule.mysubmodule.url $srcdir/shell-includes
+ git submodule update
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+ make test
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make PREFIX="${pkgdir}/usr" DESTDIR="/usr" install
+}