summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArkadiy Illarionov2021-05-05 00:19:42 +0300
committerArkadiy Illarionov2021-05-05 00:19:42 +0300
commit3f09cf0632476ef26d721f2dd094c016acbf2427 (patch)
tree6f545c3bace8136d63bcddd1e7d2cb9fb73c673c
parent8048c7b69cee6fd7ea72ff2ce0fad184d4a447c4 (diff)
downloadaur-3f09cf0632476ef26d721f2dd094c016acbf2427.tar.gz
Release 0.9.3
* drop fheroes2.sh * compile with -DCONFIGURE_FHEROES2_DATA * install fheroes2.key
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
-rw-r--r--fheroes2.sh8
3 files changed, 19 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68d2d5376788..5ee7b55f427c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fheroes2
pkgdesc = Free implementation of Heroes of Might and Magic II game engine
- pkgver = 0.9.2
+ pkgver = 0.9.3
pkgrel = 1
url = https://ihhub.github.io/fheroes2/
arch = i686
@@ -16,12 +16,10 @@ pkgbase = fheroes2
depends = tinyxml
conflicts = fheroes2-git
conflicts = fheroes2-svn
- source = fheroes2-0.9.2.tar.gz::https://github.com/ihhub/fheroes2/archive/0.9.2.tar.gz
+ source = fheroes2-0.9.3.tar.gz::https://github.com/ihhub/fheroes2/archive/0.9.3.tar.gz
source = fheroes2.desktop
- source = fheroes2.sh
- md5sums = 18a7abe4bf3b965402d20c004d64c0c2
+ md5sums = 35f7e8b3275c62293a7993492701bd4c
md5sums = 8e8e2b9097d886d9115f4541e943fa9e
- md5sums = 92708ac955c11f95590f108157659f15
pkgname = fheroes2
diff --git a/PKGBUILD b/PKGBUILD
index fbe9fb7c3d16..c26bd6167a0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=fheroes2
-pkgver=0.9.2
+pkgver=0.9.3
pkgrel=1
pkgdesc="Free implementation of Heroes of Might and Magic II game engine"
arch=('i686' 'x86_64' 'armv7h')
@@ -8,25 +8,30 @@ license=('GPL2')
depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_net' 'sdl2_ttf' 'tinyxml')
makedepends=('gettext')
conflicts=('fheroes2-git' 'fheroes2-svn')
-source=($pkgname-$pkgver.tar.gz::https://github.com/ihhub/$pkgname/archive/$pkgver.tar.gz
- fheroes2.desktop
- fheroes2.sh)
-md5sums=('18a7abe4bf3b965402d20c004d64c0c2'
- '8e8e2b9097d886d9115f4541e943fa9e'
- '92708ac955c11f95590f108157659f15')
+source=(
+ $pkgname-$pkgver.tar.gz::https://github.com/ihhub/$pkgname/archive/$pkgver.tar.gz
+ fheroes2.desktop
+)
+md5sums=(
+ '35f7e8b3275c62293a7993492701bd4c'
+ '8e8e2b9097d886d9115f4541e943fa9e'
+)
build() {
cd "$srcdir/$pkgname-$pkgver"
+ export CFLAGS+=' -DCONFIGURE_FHEROES2_DATA=\"/usr/share/fheroes2\"'
+ export CXXFLAGS+=' -DCONFIGURE_FHEROES2_DATA=\"/usr/share/fheroes2\"'
make RELEASE=1 WITHOUT_BUNDLED_LIBS=1
}
package() {
cd "$srcdir/$pkgname-$pkgver"
install -Dm644 "$srcdir/fheroes2.desktop" "$pkgdir/usr/share/applications/fheroes2.desktop"
- install -Dm755 "$srcdir/fheroes2.sh" "$pkgdir/usr/bin/fheroes2"
-
- install -Dm755 "src/dist/fheroes2" "$pkgdir/usr/share/fheroes2/fheroes2"
- install -dm755 "$pkgdir/usr/share/fheroes2/data" "$pkgdir/usr/share/fheroes2/maps"
+ install -Dm644 "fheroes2.key" "$pkgdir/usr/share/fheroes2/fheroes2.key"
+
+ install -Dm755 "src/dist/fheroes2" "$pkgdir/usr/bin/fheroes2"
+ install -dm755 "$pkgdir/usr/share/fheroes2/data"
+ install -dm755 "$pkgdir/usr/share/fheroes2/maps"
}
# vim:set ts=2 sw=2 et:
diff --git a/fheroes2.sh b/fheroes2.sh
deleted file mode 100644
index c7ec7a92e55f..000000000000
--- a/fheroes2.sh
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-CONFIG_DIR=~/.fheroes2
-
-mkdir -p $CONFIG_DIR/files/save
-cd $CONFIG_DIR || exit
-ln -sf /usr/share/fheroes2/* .
-exec ./fheroes2 $*