summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArkadiy Illarionov2023-02-08 20:17:58 +0300
committerArkadiy Illarionov2023-02-08 20:18:49 +0300
commit4b0dc836eb050561a526931b8f085ec74ec4ea0f (patch)
tree538690329934b59ddc8c60143a952b7f9e9b1b80
parentf73945d5854c9f7977f82a8625f8438fffe246f9 (diff)
downloadaur-4b0dc836eb050561a526931b8f085ec74ec4ea0f.tar.gz
Release 1.0.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44e29537fb56..07f8f871c50b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fheroes2
pkgdesc = Recreation of the Heroes of Might and Magic II game engine
- pkgver = 1.0.0
- pkgrel = 2
+ pkgver = 1.0.1
+ pkgrel = 1
url = https://ihhub.github.io/fheroes2/
arch = i686
arch = x86_64
@@ -14,11 +14,12 @@ pkgbase = fheroes2
depends = sdl2_image
depends = sdl2_mixer
optdepends = curl: download demo version files
+ optdepends = innoextract: extract game resources from installer package
optdepends = python: extract animation resources from GOG CD image
optdepends = wget: download demo version files
optdepends = unzip: unpack demo version files
conflicts = fheroes2-git
- source = fheroes2-1.0.0.tar.gz::https://github.com/ihhub/fheroes2/archive/1.0.0.tar.gz
- sha256sums = 80468b4eaf128ac5179a3416a02e2a2ef4ab34d90876b179fccd8d505f950440
+ source = fheroes2-1.0.1.tar.gz::https://github.com/ihhub/fheroes2/archive/1.0.1.tar.gz
+ sha256sums = 1e913cffec5cd29671b0aecdb55f1792887ec315f45978abfe8b0c1a1b0b642b
pkgname = fheroes2
diff --git a/PKGBUILD b/PKGBUILD
index 1320161e99a2..c3412a5bda49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
pkgname=fheroes2
-pkgver=1.0.0
-pkgrel=2
+pkgver=1.0.1
+pkgrel=1
pkgdesc="Recreation of the Heroes of Might and Magic II game engine"
arch=('i686' 'x86_64' 'armv7h')
url="https://ihhub.github.io/fheroes2/"
license=('GPL2')
depends=('sdl2' 'sdl2_image' 'sdl2_mixer')
-optdepends=('curl: download demo version files'
- 'python: extract animation resources from GOG CD image'
- 'wget: download demo version files'
- 'unzip: unpack demo version files')
+optdepends=(
+ 'curl: download demo version files'
+ 'innoextract: extract game resources from installer package'
+ 'python: extract animation resources from GOG CD image'
+ 'wget: download demo version files'
+ 'unzip: unpack demo version files'
+)
makedepends=('cmake' 'gettext' 'ninja')
conflicts=('fheroes2-git')
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/ihhub/$pkgname/archive/$pkgver.tar.gz"
)
-sha256sums=('80468b4eaf128ac5179a3416a02e2a2ef4ab34d90876b179fccd8d505f950440')
+sha256sums=('1e913cffec5cd29671b0aecdb55f1792887ec315f45978abfe8b0c1a1b0b642b')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -25,6 +28,7 @@ build() {
cmake --build build
+ # build man page
make -C docs
}