summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArkadiy Illarionov2023-03-12 18:37:07 +0300
committerArkadiy Illarionov2023-03-12 18:37:07 +0300
commit63a7d43ce5e6750a27f9233d644ef1012c7af558 (patch)
tree7134db46010f7b8f715b2415e007c5a8f01406c3
parent4b0dc836eb050561a526931b8f085ec74ec4ea0f (diff)
downloadaur-63a7d43ce5e6750a27f9233d644ef1012c7af558.tar.gz
Release 1.0.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07f8f871c50b..605b99accdbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fheroes2
pkgdesc = Recreation of the Heroes of Might and Magic II game engine
- pkgver = 1.0.1
+ pkgver = 1.0.2
pkgrel = 1
url = https://ihhub.github.io/fheroes2/
arch = i686
@@ -10,7 +10,7 @@ pkgbase = fheroes2
makedepends = cmake
makedepends = gettext
makedepends = ninja
- depends = sdl2
+ depends = hicolor-icon-theme
depends = sdl2_image
depends = sdl2_mixer
optdepends = curl: download demo version files
@@ -19,7 +19,7 @@ pkgbase = fheroes2
optdepends = wget: download demo version files
optdepends = unzip: unpack demo version files
conflicts = fheroes2-git
- source = fheroes2-1.0.1.tar.gz::https://github.com/ihhub/fheroes2/archive/1.0.1.tar.gz
- sha256sums = 1e913cffec5cd29671b0aecdb55f1792887ec315f45978abfe8b0c1a1b0b642b
+ source = fheroes2-1.0.2.tar.gz::https://github.com/ihhub/fheroes2/archive/1.0.2.tar.gz
+ sha256sums = f4f85ef4b46af354abef11e813ed10d8360498620514ff9809a3844bdca52238
pkgname = fheroes2
diff --git a/PKGBUILD b/PKGBUILD
index c3412a5bda49..36c841c6a843 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
pkgname=fheroes2
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
pkgdesc="Recreation of the Heroes of Might and Magic II game engine"
arch=('i686' 'x86_64' 'armv7h')
url="https://ihhub.github.io/fheroes2/"
license=('GPL2')
-depends=('sdl2' 'sdl2_image' 'sdl2_mixer')
+depends=('hicolor-icon-theme' 'sdl2_image' 'sdl2_mixer')
optdepends=(
'curl: download demo version files'
'innoextract: extract game resources from installer package'
@@ -18,12 +18,13 @@ conflicts=('fheroes2-git')
source=(
"$pkgname-$pkgver.tar.gz::https://github.com/ihhub/$pkgname/archive/$pkgver.tar.gz"
)
-sha256sums=('1e913cffec5cd29671b0aecdb55f1792887ec315f45978abfe8b0c1a1b0b642b')
+sha256sums=('f4f85ef4b46af354abef11e813ed10d8360498620514ff9809a3844bdca52238')
build() {
cd "$srcdir/$pkgname-$pkgver"
cmake -B build -G Ninja -S . \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr
cmake --build build