summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArkadiy Illarionov2021-12-05 19:03:38 +0300
committerArkadiy Illarionov2021-12-05 19:03:38 +0300
commita47c52be77cc432ed5735ec6caacbf5f80e4ab3a (patch)
treea4d3770e36f249553c4d26ef40783477531a2936
parent002cb8597f7bf2a59be687703587010da9c63eba (diff)
downloadaur-a47c52be77cc432ed5735ec6caacbf5f80e4ab3a.tar.gz
Release 0.9.9
* Add extract_homm2_resources.sh script * Remove RELEASE make flag
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec81df557e76..1cf8ed99a8d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fheroes2
pkgdesc = Free Heroes of Might and Magic II (fheroes2) is a recreation of HoMM2 game engine
- pkgver = 0.9.9
+ pkgver = 0.9.10
pkgrel = 1
url = https://ihhub.github.io/fheroes2/
arch = i686
@@ -16,7 +16,7 @@ pkgbase = fheroes2
optdepends = unzip: unpack demo version files
conflicts = fheroes2-git
conflicts = fheroes2-svn
- source = fheroes2-0.9.9.tar.gz::https://github.com/ihhub/fheroes2/archive/0.9.9.tar.gz
- md5sums = e7b9522d3abe3118b87d6dc25c3ef241
+ source = fheroes2-0.9.10.tar.gz::https://github.com/ihhub/fheroes2/archive/0.9.10.tar.gz
+ md5sums = fed0c50a9f04dcd4c4e915cecbfb691a
pkgname = fheroes2
diff --git a/PKGBUILD b/PKGBUILD
index 4145671094a2..9fb77b42e705 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=fheroes2
-pkgver=0.9.9
+pkgver=0.9.10
pkgrel=1
pkgdesc="Free Heroes of Might and Magic II (fheroes2) is a recreation of HoMM2 game engine"
arch=('i686' 'x86_64' 'armv7h')
@@ -15,14 +15,14 @@ source=(
$pkgname-$pkgver.tar.gz::https://github.com/ihhub/$pkgname/archive/$pkgver.tar.gz
)
md5sums=(
- 'e7b9522d3abe3118b87d6dc25c3ef241'
+ 'fed0c50a9f04dcd4c4e915cecbfb691a'
)
build() {
cd "$srcdir/$pkgname-$pkgver"
export CFLAGS+=' -DCONFIGURE_FHEROES2_DATA=\"/usr/share/fheroes2\"'
export CXXFLAGS+=' -DCONFIGURE_FHEROES2_DATA=\"/usr/share/fheroes2\"'
- make RELEASE=1 FHEROES2_IMAGE_SUPPORT=1
+ make FHEROES2_IMAGE_SUPPORT=1
make -C files/lang
}
@@ -38,6 +38,7 @@ package() {
install -Dm644 files/lang/*.mo "$pkgdir/usr/share/fheroes2/files/lang"
install -dm755 "$pkgdir/usr/share/fheroes2/maps"
install -Dm755 "script/demo/download_demo_version.sh" "$pkgdir/usr/share/fheroes2/download_demo_version.sh"
+ install -Dm755 "script/homm2/extract_homm2_resources.sh" "$pkgdir/usr/share/fheroes2/extract_homm2_resources.sh"
install -Dm644 "fheroes2.key" "$pkgdir/usr/share/fheroes2/fheroes2.key"
install -Dm644 src/resources/fheroes2.png "$pkgdir/usr/share/pixmaps/fheroes2.png"
}