summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArkadiy Illarionov2021-05-05 01:01:41 +0300
committerArkadiy Illarionov2021-05-05 01:01:41 +0300
commita9ca5adb1d14f5679a779f1af197e08a2433b250 (patch)
treeb24591a286d995f0015d61fa5ba5074c849b028a
parent3f09cf0632476ef26d721f2dd094c016acbf2427 (diff)
downloadaur-a9ca5adb1d14f5679a779f1af197e08a2433b250.tar.gz
Restore fheroes2.sh
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--fheroes2.desktop2
-rw-r--r--fheroes2.sh7
4 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ee7b55f427c..a51cef3ae6b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fheroes2
pkgdesc = Free implementation of Heroes of Might and Magic II game engine
pkgver = 0.9.3
- pkgrel = 1
+ pkgrel = 2
url = https://ihhub.github.io/fheroes2/
arch = i686
arch = x86_64
@@ -18,8 +18,10 @@ pkgbase = fheroes2
conflicts = fheroes2-svn
source = fheroes2-0.9.3.tar.gz::https://github.com/ihhub/fheroes2/archive/0.9.3.tar.gz
source = fheroes2.desktop
+ source = fheroes2.sh
md5sums = 35f7e8b3275c62293a7993492701bd4c
- md5sums = 8e8e2b9097d886d9115f4541e943fa9e
+ md5sums = 1fd1acd411fd906d56add9d7cc74c97d
+ md5sums = 2ac492a97328fd48f73e572e6f8b8ceb
pkgname = fheroes2
diff --git a/PKGBUILD b/PKGBUILD
index c26bd6167a0e..e50e3c605063 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=fheroes2
pkgver=0.9.3
-pkgrel=1
+pkgrel=2
pkgdesc="Free implementation of Heroes of Might and Magic II game engine"
arch=('i686' 'x86_64' 'armv7h')
url="https://ihhub.github.io/fheroes2/"
@@ -11,10 +11,12 @@ conflicts=('fheroes2-git' 'fheroes2-svn')
source=(
$pkgname-$pkgver.tar.gz::https://github.com/ihhub/$pkgname/archive/$pkgver.tar.gz
fheroes2.desktop
+ fheroes2.sh
)
md5sums=(
'35f7e8b3275c62293a7993492701bd4c'
- '8e8e2b9097d886d9115f4541e943fa9e'
+ '1fd1acd411fd906d56add9d7cc74c97d'
+ '2ac492a97328fd48f73e572e6f8b8ceb'
)
build() {
@@ -27,9 +29,10 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
install -Dm644 "$srcdir/fheroes2.desktop" "$pkgdir/usr/share/applications/fheroes2.desktop"
- install -Dm644 "fheroes2.key" "$pkgdir/usr/share/fheroes2/fheroes2.key"
+ install -Dm755 "$srcdir/fheroes2.sh" "$pkgdir/usr/bin/fheroes2.sh"
install -Dm755 "src/dist/fheroes2" "$pkgdir/usr/bin/fheroes2"
+ install -Dm644 "fheroes2.key" "$pkgdir/usr/share/fheroes2/fheroes2.key"
install -dm755 "$pkgdir/usr/share/fheroes2/data"
install -dm755 "$pkgdir/usr/share/fheroes2/maps"
}
diff --git a/fheroes2.desktop b/fheroes2.desktop
index c8dcea9a0765..6e49691970c3 100644
--- a/fheroes2.desktop
+++ b/fheroes2.desktop
@@ -1,5 +1,5 @@
[Desktop Entry]
-Exec=fheroes2
+Exec=fheroes2.sh
;Icon=fheroes2
Type=Application
Terminal=false
diff --git a/fheroes2.sh b/fheroes2.sh
new file mode 100644
index 000000000000..cb94b8a85773
--- /dev/null
+++ b/fheroes2.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+CONFIG_DIR=~/.fheroes2
+
+mkdir -p $CONFIG_DIR
+cd $CONFIG_DIR || exit
+exec fheroes2 $*