summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArkadiy Illarionov2021-03-06 14:38:27 +0300
committerArkadiy Illarionov2021-03-06 14:38:27 +0300
commitba584e130400f337c203e0afb9a145396451d5b0 (patch)
treea69bbe638dfdf4e3d2aceb2c44a51bfdbec836d6
downloadaur-ba584e130400f337c203e0afb9a145396451d5b0.tar.gz
Init fheroes2
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD32
-rw-r--r--fheroes2.desktop7
-rw-r--r--fheroes2.sh8
4 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8918f8b41838
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = fheroes2
+ pkgdesc = Free implementation of Heroes of Might and Magic II game engine
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = https://ihhub.github.io/fheroes2/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL
+ makedepends = gettext
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_net
+ depends = sdl2_ttf
+ depends = tinyxml
+ conflicts = fheroes2-git
+ conflicts = fheroes2-svn
+ source = fheroes2-0.9.1.tar.gz::https://github.com/ihhub/fheroes2/archive/0.9.1.tar.gz
+ source = fheroes2.desktop
+ source = fheroes2.sh
+ md5sums = e0903268ff9ae6c57d040a43c8f91c4b
+ md5sums = 8e8e2b9097d886d9115f4541e943fa9e
+ md5sums = 92708ac955c11f95590f108157659f15
+
+pkgname = fheroes2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b80a8003f99c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=fheroes2
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="Free implementation of Heroes of Might and Magic II game engine"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://ihhub.github.io/fheroes2/"
+license=('GPL')
+depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_net' 'sdl2_ttf' 'tinyxml')
+makedepends=('gettext')
+conflicts=('fheroes2-git' 'fheroes2-svn')
+source=($pkgname-$pkgver.tar.gz::https://github.com/ihhub/$pkgname/archive/$pkgver.tar.gz
+ fheroes2.desktop
+ fheroes2.sh)
+md5sums=('e0903268ff9ae6c57d040a43c8f91c4b'
+ '8e8e2b9097d886d9115f4541e943fa9e'
+ '92708ac955c11f95590f108157659f15')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make RELEASE=1 WITHOUT_BUNDLED_LIBS=1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm644 "$srcdir/fheroes2.desktop" "$pkgdir/usr/share/applications/fheroes2.desktop"
+ install -Dm755 "$srcdir/fheroes2.sh" "$pkgdir/usr/bin/fheroes2"
+
+ install -Dm755 "src/dist/fheroes2" "$pkgdir/usr/share/fheroes2/fheroes2"
+ install -dm755 "$pkgdir/usr/share/fheroes2/data" "$pkgdir/usr/share/fheroes2/maps"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/fheroes2.desktop b/fheroes2.desktop
new file mode 100644
index 000000000000..c8dcea9a0765
--- /dev/null
+++ b/fheroes2.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Exec=fheroes2
+;Icon=fheroes2
+Type=Application
+Terminal=false
+Name=Free Heroes 2
+Categories=Application;Game
diff --git a/fheroes2.sh b/fheroes2.sh
new file mode 100644
index 000000000000..c7ec7a92e55f
--- /dev/null
+++ b/fheroes2.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+CONFIG_DIR=~/.fheroes2
+
+mkdir -p $CONFIG_DIR/files/save
+cd $CONFIG_DIR || exit
+ln -sf /usr/share/fheroes2/* .
+exec ./fheroes2 $*