summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormyles2015-07-09 14:26:57 +0100
committermyles2015-07-09 14:26:57 +0100
commitb476125cee455035df1089838dc0945b3f4a65d0 (patch)
tree2fa5f3073eaf20ba1ebe16801fcce50753f3eb12
downloadaur-b476125cee455035df1089838dc0945b3f4a65d0.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..815cccae38b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fiat-git
+ pkgdesc = Supports generation of arbitrary order instances of the Lagrange elements on lines, triangles, and tetrahedra.
+ pkgver = 20140214
+ pkgrel = 1
+ url = https://bitbucket.org/fenics-project/fiat
+ arch = i686
+ arch = x86_64
+ groups = fenics-git
+ license = LGPL
+ depends = python2
+ depends = python2-scientificpython
+ provides = fiat
+ conflicts = fiat
+ options = !emptydirs
+ source = fiat::git+https://bitbucket.org/fenics-project/fiat.git#branch=master
+ md5sums = SKIP
+
+pkgname = fiat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20f0f03d583c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Myles English <myles at rockhead dot biz>
+pkgname=fiat-git
+pkgdesc="Supports generation of arbitrary order instances of the Lagrange elements on lines, triangles, and tetrahedra."
+pkgver=20140214
+pkgrel=1
+_branch=master
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/fenics-project/fiat"
+license=('LGPL')
+groups=('fenics-git')
+depends=('python2' 'python2-scientificpython')
+provides=('fiat')
+conflicts=('fiat')
+options=(!emptydirs)
+source=("fiat::git+https://bitbucket.org/fenics-project/fiat.git#branch=${_branch}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd fiat
+ git log --format="%cd" --date=short -1 | sed 's/-//g'
+}
+
+prepare() {
+ cd fiat
+ find ./ -name "*" -type f -exec \
+ sed -i 's|^#!.*python$|#!/usr/bin/python2|' {} \;
+}
+
+build() {
+ cd fiat
+ python2 setup.py build
+}
+
+package() {
+ cd fiat
+ python2 setup.py install --prefix=/usr --root="${pkgdir}"
+}