summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Hornich2020-02-07 11:02:01 +0100
committerJulian Hornich2020-02-07 11:02:01 +0100
commit2d8c803c3af485abdb0e6c68d1372489f7a7c82b (patch)
treeda124143b34e63dc09d48ac90d1332e8b855eb46
downloadaur-2d8c803c3af485abdb0e6c68d1372489f7a7c82b.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f984ca8fa4ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fiat-hpc-git
+ pkgdesc = Supports generation of arbitrary order instances of the Lagrange elements on lines, triangles, and tetrahedra. HPC version
+ pkgver = 1.4.0_20200109
+ pkgrel = 1
+ url = https://bitbucket.org/adaptivesimulations/fiat-hpc
+ arch = i686
+ arch = x86_64
+ groups = dolfin-hpc-git
+ license = LGPL
+ depends = python
+ depends = python-numpy
+ provides = fiat-hpc
+ conflicts = fiat
+ options = !emptydirs
+ source = fiat::git+https://bitbucket.org/adaptivesimulations/fiat-hpc.git#branch=feature/python3
+ md5sums = SKIP
+
+pkgname = fiat-hpc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba548626f008
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Julian Hornich <hornich at kth dot se>
+pkgname=fiat-hpc-git
+pkgdesc="Supports generation of arbitrary order instances of the Lagrange elements on lines, triangles, and tetrahedra. HPC version"
+pkgver=1.4.0_20200109
+pkgrel=1
+_branch=feature/python3
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/adaptivesimulations/fiat-hpc"
+license=('LGPL')
+groups=('dolfin-hpc-git')
+depends=('python' 'python-numpy')
+provides=('fiat-hpc')
+conflicts=('fiat')
+options=(!emptydirs)
+source=("fiat::git+https://bitbucket.org/adaptivesimulations/fiat-hpc.git#branch=${_branch}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd fiat
+ echo "$(grep version setup.py | sed 's/.*="//;s/".*//g')_$(git log --format="%cd" --date=short -1 | sed 's/-//g')"
+}
+
+prepare() {
+ cd fiat
+}
+
+build() {
+ cd fiat
+ python setup.py build
+}
+
+package() {
+ cd fiat
+ python setup.py install --prefix=/usr --root="${pkgdir}"
+}