summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:09:01 -0400
committerKyle Keen2015-06-13 00:09:01 -0400
commitbeee0e10da9f03327522144ba9c1f92ba0483216 (patch)
tree48bc5ddd0da54abca9f9887674b9d9987f32540d
downloadaur-beee0e10da9f03327522144ba9c1f92ba0483216.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..491407c50c88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ficl
+ pkgdesc = Forth Inspired Command Language
+ pkgver = 4.1.0
+ pkgrel = 1
+ url = http://ficl.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = custom:ficl
+ depends = glibc
+ optdepends = rlwrap: for a decent repl
+ source = http://downloads.sourceforge.net/project/ficl/ficl-all/ficl4.1/ficl-4.1.0.tar.gz?download
+ md5sums = 668f12c0006b2d338c3087c53311e658
+
+pkgname = ficl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e715bbc679c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+pkgname=ficl
+pkgver=4.1.0
+pkgrel=1
+pkgdesc="Forth Inspired Command Language"
+arch=('i686' 'x86_64')
+url="http://ficl.sourceforge.net"
+license=('custom:ficl')
+depends=('glibc')
+optdepends=('rlwrap: for a decent repl')
+source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname-all/ficl4.1/$pkgname-$pkgver.tar.gz?download)
+md5sums=('668f12c0006b2d338c3087c53311e658')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 ficl "$pkgdir/usr/bin/ficl"
+ install -Dm644 doc/license.html "$pkgdir/usr/share/licenses/ficl/LICENSE"
+ install -d doc/ "$pkgdir/usr/share/doc/ficl/"
+ install -d contrib/xclasses "$pkgdir/usr/share/doc/ficl/xclasses/"
+ cp -r doc/ "$pkgdir/usr/share/doc/ficl/"
+ cp -r contrib/xclasses "$pkgdir/usr/share/doc/ficl/xclasses/"
+}
+
+