summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuido2015-06-16 18:15:01 +0200
committerGuido2015-06-16 18:15:01 +0200
commitb1c982dcdf8a22f134412a9d721e9406625ff865 (patch)
tree515e8083169919d641d18f484324c4742eef725d
downloadaur-b1c982dcdf8a22f134412a9d721e9406625ff865.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
-rw-r--r--fics-timeseal.install7
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..552fdb447ebd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fics-timeseal
+ pkgdesc = Timeseal support for eboard, xboard, scid and maybe others for playing chess on FICS
+ pkgver = 1
+ pkgrel = 4
+ url = http://www.freechess.org/
+ install = fics-timeseal.install
+ arch = any
+ license = unknown
+ optdepends = eboard: works automagically
+ optdepends = xboard: run fics-xboard-timeseal from a terminal
+ optdepends = scid: before connecting browse and select /usr/bin/timeseal
+ source = http://sourceforge.net/p/scidvspc/code/HEAD/tree/timeseal/timeseal.Linux-i386?format=raw
+ md5sums = b30dd4fafb3ac1c87804e0ab2fc7bdd7
+
+pkgname = fics-timeseal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d3fc9022278
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: scorici <scorici AT yahoo DOT com>
+pkgname=fics-timeseal
+pkgver=1
+pkgrel=4
+pkgdesc="Timeseal support for eboard, xboard, scid and maybe others for playing chess on FICS"
+arch=(any)
+url="http://www.freechess.org/"
+license=('unknown')
+install=$pkgname.install
+optdepends=('eboard: works automagically' \
+ 'xboard: run fics-xboard-timeseal from a terminal' \
+ 'scid: before connecting browse and select /usr/bin/timeseal')
+source=("http://sourceforge.net/p/scidvspc/code/HEAD/tree/timeseal/timeseal.Linux-i386?format=raw")
+md5sums=('b30dd4fafb3ac1c87804e0ab2fc7bdd7')
+package() {
+mkdir -p $pkgdir/usr/bin $pkgdir/usr/share/eboard
+cp timeseal.Linux-i386\?format=raw $pkgdir/usr/bin/timeseal
+echo "#!/bin/bash
+if [ -a /usr/bin/xboard ];then
+xboard -ics -icshost 69.36.243.188 -telnet -telnetProgram timeseal
+echo
+echo
+echo Connection to freechess.org lost\!
+echo If you were in the middle of a game reconnect to resume it.
+else echo xboard is not installed on your system
+fi
+" > $pkgdir/usr/bin/fics-xboard-timeseal
+chmod +x $pkgdir/usr/bin/*timeseal
+ln -s /usr/bin/timeseal $pkgdir/usr/share/eboard/timeseal.Linux
+}
diff --git a/fics-timeseal.install b/fics-timeseal.install
new file mode 100644
index 000000000000..35f636ce87e0
--- /dev/null
+++ b/fics-timeseal.install
@@ -0,0 +1,7 @@
+post_install() {
+echo To find out if it works, after connecting type the following:
+echo \"finger\"
+echo \(without the quotes\)
+echo and if it is enabled at the bottom it will show:
+echo \"Timeseal 1 : On\"
+} \ No newline at end of file