summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Reeder2016-01-10 18:12:09 +0000
committerColin Reeder2016-01-10 18:12:09 +0000
commit58dce071b81620fa5b887ef1eb58bb7cc087de45 (patch)
treedc25ee9cfb36c19589e01054c1f8530bd7fb99ae
downloadaur-58dce071b81620fa5b887ef1eb58bb7cc087de45.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..accb451be5a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Jan 10 18:11:55 UTC 2016
+pkgbase = fictional-pancake
+ pkgdesc = A text adventure game
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/fictional-pancake/fictional-pancake
+ arch = any
+ license = MIT
+ makedepends = apache-ant
+ depends = java-runtime-headless
+ source = https://github.com/fictional-pancake/fictional-pancake/archive/v1.0.zip
+ source = https://vpzomtrrfrt.github.io/fpaur.sh
+ md5sums = SKIP
+ md5sums = 3db8b6d98a064d92e0ffc0ca04f1afe2
+
+pkgname = fictional-pancake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5805d11f38e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=fictional-pancake
+pkgdesc='A text adventure game'
+pkgrel=1
+pkgver=1.0
+arch=('any')
+license=('MIT')
+url="https://github.com/$pkgname/$pkgname"
+depends=('java-runtime-headless')
+makedepends=('apache-ant')
+source=(
+ "https://github.com/$pkgname/$pkgname/archive/v$pkgver.zip"
+ "https://vpzomtrrfrt.github.io/fpaur.sh"
+ )
+md5sums=(
+ 'SKIP'
+ '3db8b6d98a064d92e0ffc0ca04f1afe2'
+ )
+package () {
+ mkdir -p $pkgdir/usr/share/java/fictional-pancake
+ mkdir -p $pkgdir/usr/bin
+ install -Dm755 "$srcdir/fpaur.sh" "$pkgdir/usr/bin/fictional-pancake"
+ cd $srcdir/$pkgname-$pkgver
+ ant jar
+ install -Dm755 apcsgame.jar $pkgdir/usr/share/java/fictional-pancake
+}