summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Reeder2019-06-16 21:10:28 -0600
committerColin Reeder2019-06-16 21:11:00 -0600
commit7feb29d70da8e3f4b38f6ebae8b89a4c684d5a81 (patch)
treec494b4598aebeb268e91e0ccda1fea5a3be5d072
parent58dce071b81620fa5b887ef1eb58bb7cc087de45 (diff)
downloadaur-7feb29d70da8e3f4b38f6ebae8b89a4c684d5a81.tar.gz
Move startup script to local
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
-rw-r--r--fpaur.sh2
4 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index accb451be5a0..2f6d9baeebc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-# Generated by mksrcinfo v8
-# Sun Jan 10 18:11:55 UTC 2016
pkgbase = fictional-pancake
pkgdesc = A text adventure game
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fictional-pancake/fictional-pancake
arch = any
license = MIT
makedepends = apache-ant
depends = java-runtime-headless
source = https://github.com/fictional-pancake/fictional-pancake/archive/v1.0.zip
- source = https://vpzomtrrfrt.github.io/fpaur.sh
- md5sums = SKIP
- md5sums = 3db8b6d98a064d92e0ffc0ca04f1afe2
+ source = fpaur.sh
+ sha256sums = 25cef4bc263d9e32b211218c4ff0e0c5a3446409fdd8f1af4e16131107b705bc
+ sha256sums = 2ab290abb981786b048953d67a64602a4f4e84280669ba16d9fc9f6e6ae51e63
pkgname = fictional-pancake
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..93e26fdfdecd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.*
+/pkg
+/src
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index e5805d11f38e..9ebd732eec64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
pkgname=fictional-pancake
pkgdesc='A text adventure game'
-pkgrel=1
+pkgrel=2
pkgver=1.0
arch=('any')
license=('MIT')
-url="https://github.com/$pkgname/$pkgname"
+url="https://github.com/fictional-pancake/$pkgname"
depends=('java-runtime-headless')
makedepends=('apache-ant')
source=(
- "https://github.com/$pkgname/$pkgname/archive/v$pkgver.zip"
- "https://vpzomtrrfrt.github.io/fpaur.sh"
- )
-md5sums=(
- 'SKIP'
- '3db8b6d98a064d92e0ffc0ca04f1afe2'
- )
-package () {
+ "https://github.com/fictional-pancake/$pkgname/archive/v$pkgver.zip"
+ "fpaur.sh"
+)
+sha256sums=('25cef4bc263d9e32b211218c4ff0e0c5a3446409fdd8f1af4e16131107b705bc'
+ '2ab290abb981786b048953d67a64602a4f4e84280669ba16d9fc9f6e6ae51e63')
+
+package() {
mkdir -p $pkgdir/usr/share/java/fictional-pancake
mkdir -p $pkgdir/usr/bin
install -Dm755 "$srcdir/fpaur.sh" "$pkgdir/usr/bin/fictional-pancake"
diff --git a/fpaur.sh b/fpaur.sh
new file mode 100644
index 000000000000..7a8156079973
--- /dev/null
+++ b/fpaur.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -jar /usr/share/java/fictional-pancake/apcsgame.jar