summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-12 16:30:21 +0800
committerzxp198210052023-09-12 16:30:21 +0800
commit28aeaab29028f3f10f9f0f70646fc6508c539543 (patch)
tree26b104686845d8dc2dded15b82ddd20604714dc4
parent5af548a4455070e570cf1f051aee5013ed240793 (diff)
downloadaur-28aeaab29028f3f10f9f0f70646fc6508c539543.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b67a3cf808d0..8178c585d079 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ficus-bin
pkgdesc = A software for editing and managing markdown documents, developed by the gg=G team.
pkgver = 0.2.1
- pkgrel = 3
+ pkgrel = 4
url = https://ficus.world/
arch = x86_64
license = MIT
@@ -12,8 +12,8 @@ pkgbase = ficus-bin
conflicts = ficus
conflicts = ficus-desktop
source = ficus-0.2.1.asar::https://github.com/Thysrael/Ficus/releases/download/v0.2.1/app.asar
- source = https://raw.githubusercontent.com/Thysrael/Ficus/main/LICENSE
- source = ficus.png::https://raw.githubusercontent.com/Thysrael/Ficus/main/build/icon.png
+ source = https://raw.githubusercontent.com/Thysrael/Ficus/v0.2.1/LICENSE
+ source = ficus.png::https://raw.githubusercontent.com/Thysrael/Ficus/v0.2.1/build/icon.png
source = ficus.sh
sha256sums = fb3a407722baa7b48b81db2753ae12f47799a3a434122d47db8b320c6c4ba993
sha256sums = 062dfd6ae4c19f555ebbdba752598c98510837687393a38a3602b711890430d7
diff --git a/PKGBUILD b/PKGBUILD
index f26b6fb9e71d..7df6ac27de45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=ficus-bin
pkgver=0.2.1
-pkgrel=3
+pkgrel=4
pkgdesc="A software for editing and managing markdown documents, developed by the gg=G team."
arch=('x86_64')
url="https://ficus.world/"
@@ -12,18 +12,20 @@ conflicts=("${pkgname%-bin}" "${pkgname%-bin}-desktop")
depends=('bash' 'electron13')
makedepends=('gendesk')
source=("${pkgname%-bin}-${pkgver}.asar::${_githuburl}/releases/download/v${pkgver}/app.asar"
- "https://raw.githubusercontent.com/Thysrael/Ficus/main/LICENSE"
- "${pkgname%-bin}.png::https://raw.githubusercontent.com/Thysrael/Ficus/main/build/icon.png"
+ "https://raw.githubusercontent.com/Thysrael/Ficus/v${pkgver}/LICENSE"
+ "${pkgname%-bin}.png::https://raw.githubusercontent.com/Thysrael/Ficus/v${pkgver}/build/icon.png"
"${pkgname%-bin}.sh")
sha256sums=('fb3a407722baa7b48b81db2753ae12f47799a3a434122d47db8b320c6c4ba993'
'062dfd6ae4c19f555ebbdba752598c98510837687393a38a3602b711890430d7'
'3c8344b3daac5c775a3bf38518e5eee024566d7ea0a3f72c543a7c7ae13f72ef'
'fe17973210b46d11cfaad9baa7c821f64a26667a77ba8ca483ea8acfb1fab525')
+prepare() {
+ gendesk -f -n --categories "Utility" --name "Ficus" --exec "${pkgname%-bin}"
+}
package() {
- install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}-${pkgver}.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
- gendesk -f -n --pkgname "${pkgname%-bin}" --icon "${pkgname%-bin}" --categories "Utility" --name "Ficus" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file