summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-13 12:08:55 +0800
committerzxp198210052023-07-13 12:08:55 +0800
commit81a028e05d23b021b3630842cf4d47a3a780d86c (patch)
tree5b6e4f7118d0bc805342d40b3f528a2d610e6da0
downloadaur-81a028e05d23b021b3630842cf4d47a3a780d86c.tar.gz
first release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
-rw-r--r--ficus.sh6
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c1b06cda1f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ficus-bin
+ pkgdesc = A software for editing and managing markdown documents, developed by the gg=G team.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://ficus.world/
+ arch = x86_64
+ license = MIT
+ makedepends = gendesk
+ depends = electron13
+ conflicts = ficus
+ source = ficus-0.2.1.asar::https://github.com/Thysrael/Ficus/releases/download/v0.2.1/app.asar
+ source = https://raw.githubusercontent.com/Thysrael/Ficus/main/LICENSE
+ source = ficus.png::https://raw.githubusercontent.com/Thysrael/Ficus/main/build/icon.png
+ source = ficus.sh
+ sha256sums = fb3a407722baa7b48b81db2753ae12f47799a3a434122d47db8b320c6c4ba993
+ sha256sums = 062dfd6ae4c19f555ebbdba752598c98510837687393a38a3602b711890430d7
+ sha256sums = 3c8344b3daac5c775a3bf38518e5eee024566d7ea0a3f72c543a7c7ae13f72ef
+ sha256sums = 7efd1cbfdcaa7492e55c72e90cbd53fc0255c7e64f45a0c413a5688f9af895a8
+
+pkgname = ficus-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbf48242df62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="ficus-bin"
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A software for editing and managing markdown documents, developed by the gg=G team."
+arch=('x86_64')
+url="https://ficus.world/"
+_githuburl="https://github.com/Thysrael/Ficus"
+license=('MIT')
+conflicts=("${pkgname%-bin}")
+depends=('electron13')
+makedepends=('gendesk')
+source=("${pkgname%-bin}-${pkgver}.asar::${_githuburl}/releases/download/v${pkgver}/app.asar"
+ "https://raw.githubusercontent.com/Thysrael/Ficus/main/LICENSE"
+ "${pkgname%-bin}.png::https://raw.githubusercontent.com/Thysrael/Ficus/main/build/icon.png"
+ "${pkgname%-bin}.sh")
+sha256sums=('fb3a407722baa7b48b81db2753ae12f47799a3a434122d47db8b320c6c4ba993'
+ '062dfd6ae4c19f555ebbdba752598c98510837687393a38a3602b711890430d7'
+ '3c8344b3daac5c775a3bf38518e5eee024566d7ea0a3f72c543a7c7ae13f72ef'
+ '7efd1cbfdcaa7492e55c72e90cbd53fc0255c7e64f45a0c413a5688f9af895a8')
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-${pkgver}.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ gendesk -f -n --pkgname "${pkgname%-bin}" --icon "${pkgname%-bin}" --categories "Utility" --name "Ficus" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file
diff --git a/ficus.sh b/ficus.sh
new file mode 100644
index 000000000000..fb1dc0a14531
--- /dev/null
+++ b/ficus.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron13 /opt/ficus/ficus.asar "$@"
+else
+ exec electron13 --no-sandbox /opt/ficus/ficus.asar "$@"
+fi \ No newline at end of file