summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent van Donselaar2013-11-08 23:31:50 +0100
committerVincent van Donselaar2015-06-30 20:44:49 +0200
commitcc75f187e301e1812783be2b3cfb0f28ad17d25e (patch)
treebbb2a768e1eec9113675632464613aac7f0f1fda
downloadaur-cc75f187e301e1812783be2b3cfb0f28ad17d25e.tar.gz
Fist version
Included desktop file Bacam any build Updated to 4.4.8.4 Add .SRCINFO which is apparently required for AUR4.
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE16
-rw-r--r--PKGBUILD38
-rw-r--r--fiddler.desktop8
-rw-r--r--fiddler.pngbin0 -> 1109 bytes
5 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea99e0ae634a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = fiddler
+ pkgdesc = The free web debugging proxy by Telerik (running on mono)
+ pkgver = 4.4.8.4
+ pkgrel = 1
+ url = http://getfiddler.com/
+ arch = any
+ license = custom
+ makedepends = unzip
+ depends = mono
+ source = http://ericlawrence.com/dl/MonoFiddler-v4484.zip
+ source = LICENSE
+ source = fiddler.desktop
+ source = fiddler.png
+ sha1sums = 37bd8a58d02dae2455d9517af98703e9b833e5df
+ sha1sums = 7f96e962d882d554b2a606d3f76bc3dd85c9fdd1
+ sha1sums = bee1aeabed80319c5c24b7930bf763b982675b58
+ sha1sums = f92dd0c975af05de485ad9be49b209a3d88be346
+
+pkgname = fiddler
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..38798da839bb
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,16 @@
+Retrieved from: http://fiddler2.com/license-agreement at Nov 8, 2013.
+
+---------------------------------------------------------------------
+
+NOTE: The license terms contained in the Fiddler installer are definitive and supercede the terms below.
+A copy of the Fiddler license as of 12/4/2012 is provided here for your convenience, but the terms may have changed by the time you install.
+
+By using this software and any updates to it, you indicate your acceptance of these terms. If you do not accept these terms, do not install or use the software.
+
+The software (Fiddler Web Debugger) and any updates to it are provided "as is" and you bear the risk of using it. In no event shall Telerik or I, Eric Lawrence, be liable for any consequential, special, incidental or indirect damages of any kind arising out of the delivery, performance or use of this software. This software was written with care, but no one warrants that the software is error-free. Your sole remedy for any failure or any form of damage caused by this software is a full refund of the license fee I have received from you, which in all cases is $0.
+
+On startup, the software anonymously checks for new versions; you may disable this feature if you prefer. You may opt-in to submitting anonymous data about your system configuration and use of the software to help improve future versions of the software. You may privately distribute copies of the software to others, so long as this disclaimer accompanies said distribution, you do not represent the software as your own work, and you do not alter the software or the installation package in any way. You may not host or redistribute this software publicly (e.g. from a public Internet site); instead point users to http://getfiddler.com/ to download. You may not decompile or otherwise reverse-engineer any part of the software, except and only to the extent that such actions are expressly allowed by applicable law notwithstanding this restriction.
+
+EXPORT RESTRICTIONS: The software is subject to United States export laws and regulations. You must comply with all domestic and international export laws and regulations that apply to software. These laws include restrictions on destinations, end users and end use.
+
+USE RESTRICTIONS: You warrant that your use of this software is legal and does not violate any law or regulation to which you are subject.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e34d6c7f485
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Vincent van Donselaar <vincent@van-donselaar.nl>
+pkgname=fiddler
+pkgver=4.4.8.4
+pkgrel=1
+pkgdesc="The free web debugging proxy by Telerik (running on mono)"
+arch=('any')
+url="http://getfiddler.com/"
+license=('custom')
+groups=()
+depends=('mono')
+makedepends=('unzip')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+source=("http://ericlawrence.com/dl/MonoFiddler-v4484.zip"
+ "LICENSE"
+ "fiddler.desktop"
+ "fiddler.png")
+sha1sums=('37bd8a58d02dae2455d9517af98703e9b833e5df'
+ '7f96e962d882d554b2a606d3f76bc3dd85c9fdd1'
+ 'bee1aeabed80319c5c24b7930bf763b982675b58'
+ 'f92dd0c975af05de485ad9be49b209a3d88be346')
+
+package() {
+ cd "$pkgdir"
+
+ # The license should be in /usr/share/licenses.
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Desktop file
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "${srcdir}/${pkgname}.png" "${pkgdir}/opt/${pkgname}/${pkgname}.png"
+
+ mkdir -p opt
+ cp -a "${srcdir}/app/." "${pkgdir}/opt/${pkgname}/"
+}
diff --git a/fiddler.desktop b/fiddler.desktop
new file mode 100644
index 000000000000..04d9ee2893f0
--- /dev/null
+++ b/fiddler.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Fiddler Web Debugger Proxy
+Comment=The Free Web Debugger Proxy by Telerik
+Exec=mono /opt/fiddler/Fiddler.exe %u
+Icon=/opt/fiddler/fiddler.png
+Terminal=false
+Type=Application
+Categories=Development;
diff --git a/fiddler.png b/fiddler.png
new file mode 100644
index 000000000000..4458575ca68b
--- /dev/null
+++ b/fiddler.png
Binary files differ