summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2017-09-30 20:46:29 +0200
committerJake2017-09-30 20:46:29 +0200
commite3887f9f37fa3a546310e08b6b27814fdc9cc441 (patch)
tree24949b1eccfe940371fe7b9f45af9deaa55e5c8b
parentcc75f187e301e1812783be2b3cfb0f28ad17d25e (diff)
downloadaur-e3887f9f37fa3a546310e08b6b27814fdc9cc441.tar.gz
Update to 4.6
-rw-r--r--.SRCINFO13
-rw-r--r--LICENSE16
-rw-r--r--PKGBUILD49
-rw-r--r--fiddler.pngbin1109 -> 1765 bytes
-rw-r--r--fiddler.sh3
5 files changed, 32 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea99e0ae634a..5938a9698de2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = fiddler
pkgdesc = The free web debugging proxy by Telerik (running on mono)
- pkgver = 4.4.8.4
+ pkgver = 4.6.20171.26113
pkgrel = 1
url = http://getfiddler.com/
arch = any
license = custom
- makedepends = unzip
depends = mono
- source = http://ericlawrence.com/dl/MonoFiddler-v4484.zip
- source = LICENSE
+ source = http://telerik-fiddler.s3.amazonaws.com/fiddler/fiddler-linux.zip
source = fiddler.desktop
source = fiddler.png
- sha1sums = 37bd8a58d02dae2455d9517af98703e9b833e5df
- sha1sums = 7f96e962d882d554b2a606d3f76bc3dd85c9fdd1
+ source = fiddler.sh
+ sha1sums = 112a1ae7c350d702b1dc368b24f16e3bb1843dbd
sha1sums = bee1aeabed80319c5c24b7930bf763b982675b58
- sha1sums = f92dd0c975af05de485ad9be49b209a3d88be346
+ sha1sums = da3c1afeb3a4ec8911766a548175b1138810e14d
+ sha1sums = 2f84386c418f50c10229deb8416047bae6333969
pkgname = fiddler
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 38798da839bb..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,16 +0,0 @@
-Retrieved from: http://fiddler2.com/license-agreement at Nov 8, 2013.
-
----------------------------------------------------------------------
-
-NOTE: The license terms contained in the Fiddler installer are definitive and supercede the terms below.
-A copy of the Fiddler license as of 12/4/2012 is provided here for your convenience, but the terms may have changed by the time you install.
-
-By using this software and any updates to it, you indicate your acceptance of these terms. If you do not accept these terms, do not install or use the software.
-
-The software (Fiddler Web Debugger) and any updates to it are provided "as is" and you bear the risk of using it. In no event shall Telerik or I, Eric Lawrence, be liable for any consequential, special, incidental or indirect damages of any kind arising out of the delivery, performance or use of this software. This software was written with care, but no one warrants that the software is error-free. Your sole remedy for any failure or any form of damage caused by this software is a full refund of the license fee I have received from you, which in all cases is $0.
-
-On startup, the software anonymously checks for new versions; you may disable this feature if you prefer. You may opt-in to submitting anonymous data about your system configuration and use of the software to help improve future versions of the software. You may privately distribute copies of the software to others, so long as this disclaimer accompanies said distribution, you do not represent the software as your own work, and you do not alter the software or the installation package in any way. You may not host or redistribute this software publicly (e.g. from a public Internet site); instead point users to http://getfiddler.com/ to download. You may not decompile or otherwise reverse-engineer any part of the software, except and only to the extent that such actions are expressly allowed by applicable law notwithstanding this restriction.
-
-EXPORT RESTRICTIONS: The software is subject to United States export laws and regulations. You must comply with all domestic and international export laws and regulations that apply to software. These laws include restrictions on destinations, end users and end use.
-
-USE RESTRICTIONS: You warrant that your use of this software is legal and does not violate any law or regulation to which you are subject.
diff --git a/PKGBUILD b/PKGBUILD
index 4e34d6c7f485..c7e39283bd7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,35 @@
-# Maintainer: Vincent van Donselaar <vincent@van-donselaar.nl>
+# Maintainer: Jake <ja.ke@posteo.de>
+# Last Maintainer (Submitter): Vincent van Donselaar <vincent@van-donselaar.nl>
pkgname=fiddler
-pkgver=4.4.8.4
+pkgver=4.6.20171.26113
pkgrel=1
pkgdesc="The free web debugging proxy by Telerik (running on mono)"
arch=('any')
url="http://getfiddler.com/"
license=('custom')
-groups=()
depends=('mono')
-makedepends=('unzip')
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-source=("http://ericlawrence.com/dl/MonoFiddler-v4484.zip"
- "LICENSE"
- "fiddler.desktop"
- "fiddler.png")
-sha1sums=('37bd8a58d02dae2455d9517af98703e9b833e5df'
- '7f96e962d882d554b2a606d3f76bc3dd85c9fdd1'
- 'bee1aeabed80319c5c24b7930bf763b982675b58'
- 'f92dd0c975af05de485ad9be49b209a3d88be346')
+source=("http://telerik-fiddler.s3.amazonaws.com/${pkgname}/${pkgname}-linux.zip"
+ "${pkgname}.desktop"
+ "${pkgname}.png"
+ "${pkgname}.sh")
+sha1sums=('112a1ae7c350d702b1dc368b24f16e3bb1843dbd'
+ 'bee1aeabed80319c5c24b7930bf763b982675b58'
+ 'da3c1afeb3a4ec8911766a548175b1138810e14d'
+ '2f84386c418f50c10229deb8416047bae6333969')
package() {
- cd "$pkgdir"
+ rm "${srcdir}/${pkgname}-linux.zip"
- # The license should be in /usr/share/licenses.
- install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- # Desktop file
+ cd "${pkgdir}"
+
+ install -d "${pkgdir}/opt"
+ cp -r "${srcdir}" "${pkgdir}/opt/${pkgname}"
+ install -D -m644 "${srcdir}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -D -m644 "${srcdir}/${pkgname}.png" "${pkgdir}/opt/${pkgname}/${pkgname}.png"
-
- mkdir -p opt
- cp -a "${srcdir}/app/." "${pkgdir}/opt/${pkgname}/"
+ install -D -m755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Files that get written on runtime
+ cd ${pkgdir}/opt/${pkgname}/
+ touch proxyinfo.conf proxiesFromInterfaces.txt listeningProcess.txt gsettings.txt
+ chmod 777 proxyinfo.conf proxiesFromInterfaces.txt listeningProcess.txt gsettings.txt
}
diff --git a/fiddler.png b/fiddler.png
index 4458575ca68b..e0ea9fbeea61 100644
--- a/fiddler.png
+++ b/fiddler.png
Binary files differ
diff --git a/fiddler.sh b/fiddler.sh
new file mode 100644
index 000000000000..c72b5f6c99b4
--- /dev/null
+++ b/fiddler.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /opt/fiddler/
+mono Fiddler.exe %u