summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshimun2021-07-14 12:36:18 +0200
committershimun2021-07-14 12:36:18 +0200
commit22b00148cead397d373301d439cf77f4e81eb305 (patch)
treee9b0dddce7d78de09ca486e52c4d529d59c42159
parent78c56f2b0a60ef092e6eaf34347b7232d4c109ca (diff)
downloadaur-22b00148cead397d373301d439cf77f4e81eb305.tar.gz
update to 0.2.17
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c43cd8dd6062..4e727ba76fce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fido2luks
pkgdesc = Decrypt your LUKS partition using a FIDO2 compatible authenticator
- pkgver = 0.2.16
- pkgrel = 1
+ pkgver = 0.2.17
+ pkgrel = 2
url = https://github.com/shimunn/fido2luks
arch = i686
arch = x86_64
@@ -13,8 +13,8 @@ pkgbase = fido2luks
makedepends = cryptsetup
makedepends = clang
depends = cryptsetup
- source = fido2luks-0.2.16.tar.gz::https://github.com/shimunn/fido2luks/archive/0.2.16.tar.gz
- sha256sums = 353e77753bc496fd9ac6e12c8715e49d81cd66eec57e8f17c13723fa887cbcaf
+ source = fido2luks-0.2.17.tar.gz::https://github.com/shimunn/fido2luks/archive/0.2.17.tar.gz
+ sha256sums = 5cb921c6fcd55f23d608034d488e5dd43fc2be32d33c8436828079acc3f9a741
pkgname = fido2luks
diff --git a/PKGBUILD b/PKGBUILD
index 67b53782a57e..72fe223475d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: shimunn <shimun@shimun.net>
pkgname=fido2luks
-pkgver=0.2.16
-pkgrel=1
+pkgver=0.2.17
+pkgrel=2
makedepends=('rust' 'cargo' 'cryptsetup' 'clang')
depends=('cryptsetup')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
pkgdesc="Decrypt your LUKS partition using a FIDO2 compatible authenticator"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/shimunn/${pkgname}/archive/${pkgver}.tar.gz")
# curl -L https://github.com/shimunn/fido2luks/archive/0.2.16.tar.gz | sha256sum
-sha256sums=("353e77753bc496fd9ac6e12c8715e49d81cd66eec57e8f17c13723fa887cbcaf")
+sha256sums=("5cb921c6fcd55f23d608034d488e5dd43fc2be32d33c8436828079acc3f9a741")
url="https://github.com/shimunn/fido2luks"
license=('MPL-2.0')
@@ -16,10 +16,17 @@ build() {
cd "${pkgname}-${pkgver}"
cargo build --release --locked --all-features --target-dir=target
./target/release/fido2luks completions bash target
+ ./target/release/fido2luks completions fish target
}
package() {
cd "${pkgname}-${pkgver}"
install -Dm 755 target/release/${pkgname} -t "${pkgdir}/usr/bin"
+
+ install -Dm 755 pam_mount/fido2luksmounthelper.sh -t "${pkgdir}/usr/bin"
+ install -Dm 644 initcpio/hooks/fido2luks -t "${pkgdir}/usr/lib/initcpio/hooks"
+ install -Dm 644 initcpio/install/fido2luks -t "${pkgdir}/usr/lib/initcpio/install"
+
install -Dm 644 target/fido2luks.bash "${pkgdir}/usr/share/bash-completion/completions/fido2luks"
+ install -Dm 644 target/fido2luks.fish -t "${pkgdir}/usr/share/fish/vendor_completions.d"
}