summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaravanan palanisamy2020-09-02 22:29:26 +0400
committersaravanan palanisamy2020-09-02 22:29:26 +0400
commit29cc582265ce17903ca8c74a7deabf1edaa0507e (patch)
tree4798c4885c55dd22501f9dcdb40e92fc024417da
downloadaur-29cc582265ce17903ca8c74a7deabf1edaa0507e.tar.gz
add package fido2luks
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dcd38acd36d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fido2luks
+ pkgdesc = Decrypt your LUKS partition using a FIDO2 compatible authenticator
+ pkgver = 0.2.12
+ pkgrel = 1
+ url = https://github.com/shimunn/fido2luks
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MPL-2.0
+ makedepends = rust
+ makedepends = cargo
+
+pkgname = fido2luks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9796d7b7deb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: shimunn <shimun@shimun.net>
+pkgname=fido2luks
+pkgver=0.2.12
+pkgrel=1
+makedepends=('rust' 'cargo' 'cryptsetup' 'clang')
+depends=('cryptsetup')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="Decrypt your LUKS partition using a FIDO2 compatible authenticator"
+url="https://github.com/shimunn/fido2luks"
+license=('MPL-2.0')
+
+build() {
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+package() {
+ install -Dm 755 target/release/${pkgname} -t "${pkgdir}/usr/bin"
+}