summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshimun2020-09-02 22:42:56 +0200
committershimun2020-09-02 22:42:56 +0200
commitb6fe41447f01ecedc8e2687af3ec712775155599 (patch)
tree91d74162175012d1ebdcbc6d07451ab07cacbe64
parent29cc582265ce17903ca8c74a7deabf1edaa0507e (diff)
downloadaur-b6fe41447f01ecedc8e2687af3ec712775155599.tar.gz
added source
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9796d7b7deb2..9f3489ff4f47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,17 @@ makedepends=('rust' 'cargo' 'cryptsetup' 'clang')
depends=('cryptsetup')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
pkgdesc="Decrypt your LUKS partition using a FIDO2 compatible authenticator"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/shimunn/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=("3c4baa642d0fb705a2a4c52de4d4483531e920a483904d59ba517d9bbb8dcf17")
url="https://github.com/shimunn/fido2luks"
license=('MPL-2.0')
build() {
+ cd "${pkgname}-${pkgver}"
cargo build --release --locked --all-features --target-dir=target
}
package() {
+ cd "${pkgname}-${pkgver}"
install -Dm 755 target/release/${pkgname} -t "${pkgdir}/usr/bin"
}