summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshimun2020-09-03 15:09:56 +0200
committershimun2020-09-03 15:10:46 +0200
commite946aa45c8f51be5d5b9db78a57a8e7ad35cb6e4 (patch)
tree3ca55f42b04af80a3c106269ddd29fcda6a219d1
parent7f5ed2629afc5220eef15466ad42820abb6031a0 (diff)
downloadaur-e946aa45c8f51be5d5b9db78a57a8e7ad35cb6e4.tar.gz
0.2.13
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 342bd8655024..050321f98513 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fido2luks
pkgdesc = Decrypt your LUKS partition using a FIDO2 compatible authenticator
- pkgver = 0.2.12
+ pkgver = 0.2.13
pkgrel = 1
url = https://github.com/shimunn/fido2luks
arch = i686
@@ -13,8 +13,8 @@ pkgbase = fido2luks
makedepends = cryptsetup
makedepends = clang
depends = cryptsetup
- source = fido2luks-0.2.12.tar.gz::https://github.com/shimunn/fido2luks/archive/0.2.12.tar.gz
- sha256sums = 3c4baa642d0fb705a2a4c52de4d4483531e920a483904d59ba517d9bbb8dcf17
+ source = fido2luks-0.2.12.tar.gz::https://github.com/shimunn/fido2luks/archive/0.2.13.tar.gz
+ sha256sums = 07ead0bdb99f22b0d75ff3375be954c7e034fc18322d87cece2ac0468498e34d
pkgname = fido2luks
diff --git a/PKGBUILD b/PKGBUILD
index 9f3489ff4f47..96fb9f1746fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
# Maintainer: shimunn <shimun@shimun.net>
pkgname=fido2luks
-pkgver=0.2.12
+pkgver=0.2.13
pkgrel=1
makedepends=('rust' 'cargo' 'cryptsetup' 'clang')
depends=('cryptsetup')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
pkgdesc="Decrypt your LUKS partition using a FIDO2 compatible authenticator"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/shimunn/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=("3c4baa642d0fb705a2a4c52de4d4483531e920a483904d59ba517d9bbb8dcf17")
+sha256sums=("07ead0bdb99f22b0d75ff3375be954c7e034fc18322d87cece2ac0468498e34d")
url="https://github.com/shimunn/fido2luks"
license=('MPL-2.0')
build() {
cd "${pkgname}-${pkgver}"
cargo build --release --locked --all-features --target-dir=target
+ ./target/release/fido2luks completions bash target
}
package() {
cd "${pkgname}-${pkgver}"
install -Dm 755 target/release/${pkgname} -t "${pkgdir}/usr/bin"
+ install -Dm 644 target/fido2luks.bash "${pkgdir}/usr/share/bash-completion/completions/fido2luks"
}