summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordigital_mystik2021-07-31 22:24:17 -0700
committerdigital_mystik2021-07-31 22:24:17 -0700
commit56dced1f0778be8a02595c0d98bf13544866112e (patch)
tree62ae935119331159f39bd189e5db6f86924717c4
downloadaur-56dced1f0778be8a02595c0d98bf13544866112e.tar.gz
0.2.19-1
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD36
-rw-r--r--dracut-integration-instructions.install6
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34c347f9084d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = fido2luks-bin
+ pkgdesc = Decrypt your LUKS partition using a FIDO2 compatible authenticator
+ pkgver = 0.2.19
+ pkgrel = 1
+ url = https://github.com/shimunn/fido2luks
+ install = dracut-integration-instructions.install
+ arch = x86_64
+ license = MPL-2.0
+ depends = cryptsetup
+ optdepends = dracut: booting with 2FA
+ provides = fido2luks
+ conflicts = fido2luks
+ options = !strip
+ options = !emptydirs
+ backup = etc/fido2luks.conf
+ source = https://github.com/shimunn/fido2luks/releases/download/0.2.19/fido2luks_0.2.19_amd64.deb
+ source = https://github.com/shimunn/fido2luks/releases/download/0.2.19/fido2luks_0.2.19_amd64.deb.asc
+ source = dracut-integration-instructions.install
+ validpgpkeys = 0B696CD8BD59C0628C3DC2A487999521848D6CA7
+ b2sums = e21519cdd29cc12026183e492918ef63522fa3cd2870a4f4ddf0bf9e2040f8d55de88448d3106c76a274995d30bf3e061bde40a7a9058a7e6e9ec492d836ceda
+ b2sums = SKIP
+ b2sums = 0f4cba3368e3f713064d890c8e3688721aa8dc7c59e463d20c2a00db650d71a2837c5229becd43e31b4b590650390685930d86056eab62c251220854b7a3983b
+
+pkgname = fido2luks-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3919cf6261bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+#Maintainer: digital mystik <dgtl_mystik AT protonmail DOT ch>
+#Contributer: shimun <shimun AT shimun DOT net>
+
+pkgname=fido2luks-bin
+_pkgname=fido2luks
+pkgver=0.2.19
+pkgrel=1
+pkgdesc="Decrypt your LUKS partition using a FIDO2 compatible authenticator"
+arch=('x86_64')
+url="https://github.com/shimunn/fido2luks"
+license=('MPL-2.0')
+provides=(fido2luks)
+conflicts=(fido2luks)
+depends=('cryptsetup')
+optdepends=('dracut: booting with 2FA')
+backup=('etc/fido2luks.conf')
+options=('!strip' '!emptydirs')
+validpgpkeys=('0B696CD8BD59C0628C3DC2A487999521848D6CA7')
+install=dracut-integration-instructions.install
+
+source=(
+ "https://github.com/shimunn/${_pkgname}/releases/download/${pkgver}/${_pkgname}_${pkgver}_amd64.deb"{,.asc}
+ "dracut-integration-instructions.install"
+)
+
+b2sums=(
+ 'e21519cdd29cc12026183e492918ef63522fa3cd2870a4f4ddf0bf9e2040f8d55de88448d3106c76a274995d30bf3e061bde40a7a9058a7e6e9ec492d836ceda'
+ 'SKIP'
+ '0f4cba3368e3f713064d890c8e3688721aa8dc7c59e463d20c2a00db650d71a2837c5229becd43e31b4b590650390685930d86056eab62c251220854b7a3983b')
+
+package() {
+ tar xf data.tar.xz -C "${pkgdir}"
+ install -D -m644 "${pkgdir}/usr/share/doc/fido2luks/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd ${pkgdir}
+ mkdir -p usr/lib 2> /dev/null; mv lib/* usr/lib; rm -rf lib
+}
diff --git a/dracut-integration-instructions.install b/dracut-integration-instructions.install
new file mode 100644
index 000000000000..725ea14a6a55
--- /dev/null
+++ b/dracut-integration-instructions.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo 'In order for fido2luks to integrate with dracut, one must have the proper modules installed:'
+ echo 'git clone https://github.com/shimunn/fido2luks.git'
+ echo 'cd fido2luks/dracut'
+ echo 'sudo make install'
+}