summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2021-04-05 03:57:04 +0200
committerLucki2021-04-05 03:57:04 +0200
commit2a3003abb371c524e1e78a8bc5181c992263e985 (patch)
tree447a52a00c4a6eeb8856d91e9d8df27b6b10ea38
parent6cc27d751804da57cb2df8086327ab5b9d797e95 (diff)
downloadaur-2a3003abb371c524e1e78a8bc5181c992263e985.tar.gz
upgpkg: fife 0.4.2-4
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df4475e228c1..89c0d73a171f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = fife
pkgdesc = Flexible Isometric Free Engine is a cross platform game creation framework
pkgver = 0.4.2
- pkgrel = 3
+ pkgrel = 4
url = http://fifengine.net/
arch = i686
arch = x86_64
license = LGPL
makedepends = boost
makedepends = cmake
+ makedepends = ninja
makedepends = swig
depends = boost-libs
depends = fifechan
@@ -26,9 +27,11 @@ pkgbase = fife
source = fife-0.4.2.src.tar.gz::https://github.com/fifengine/fifengine/archive/0.4.2.tar.gz
source = fife-[PATCH]-removed-flags-that-are-not-supported-with-swig-4.0.patch::https://github.com/fifengine/fifengine/commit/d14f232f4cd9a00b05d6872957070e8c020f515d.patch
source = fife-[PATCH]-SyntaxWarning:-"is"-with-a-literal.patch::https://github.com/fifengine/fifengine/commit/454a981a777f141db999809944abbc64ed15c41f.patch
+ source = fife-[PATCH]-remove-deprecated-getchildren().patch::https://github.com/fifengine/fifengine/commit/cf295fd98a8fba080f6305c27be56d10ab7ce94d.patch
sha512sums = 2b92e936d3f900532c5dee235a217c338941c44da479dceb3e48b3e8b93a402b31dc5501a6533391a01af53d6dbd51b6793c74e8ac81301ae6f1fa18271761a4
sha512sums = d5894f7708030ac6f8cc7612b4a29c1fb68aa2d545362017232874579661097ed1257b7de297489a10951716033d522d4ee6c17033009e2a4eaf3cfbdc26091d
sha512sums = 59b47dabc2b02a807c978837ab47498dca140f156159ada2c2cdbcf7a912bd95fcaf622bb92bcd585b1c722d4023f50330c4320d59a76e4ba12bb344da43996c
+ sha512sums = be566e0e2219e66c734f72a0a1c960589514cda1b4bb40e38e87587ddc1f7f17bb13bb0ab117cace4bcceb900e7e2fd3b4c84818ad77503e514f3974feda7733
pkgname = fife
diff --git a/PKGBUILD b/PKGBUILD
index 5094cc0bc14a..ed199189f21c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,22 @@
pkgname=fife
pkgver=0.4.2
-pkgrel=3
+pkgrel=4
_githubname=fifengine
pkgdesc="Flexible Isometric Free Engine is a cross platform game creation framework"
arch=('i686' 'x86_64')
url="http://fifengine.net/"
license=('LGPL')
depends=('boost-libs' 'fifechan' 'glew' 'libgl' 'libpng' 'libstdc++5' 'libvorbis' 'openal' 'python' 'sdl2' 'sdl2_image' 'sdl2_ttf' 'tinyxml' 'zlib')
-makedepends=('boost' 'cmake' 'swig')
+makedepends=('boost' 'cmake' 'ninja' 'swig')
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/$_githubname/$_githubname/archive/$pkgver.tar.gz"
"$pkgname-[PATCH]-removed-flags-that-are-not-supported-with-swig-4.0.patch::https://github.com/$_githubname/$_githubname/commit/d14f232f4cd9a00b05d6872957070e8c020f515d.patch"
- "$pkgname-[PATCH]-SyntaxWarning:-\"is\"-with-a-literal.patch::https://github.com/$_githubname/$_githubname/commit/454a981a777f141db999809944abbc64ed15c41f.patch")
+ "$pkgname-[PATCH]-SyntaxWarning:-\"is\"-with-a-literal.patch::https://github.com/$_githubname/$_githubname/commit/454a981a777f141db999809944abbc64ed15c41f.patch"
+ "$pkgname-[PATCH]-remove-deprecated-getchildren().patch::https://github.com/fifengine/fifengine/commit/cf295fd98a8fba080f6305c27be56d10ab7ce94d.patch")
sha512sums=('2b92e936d3f900532c5dee235a217c338941c44da479dceb3e48b3e8b93a402b31dc5501a6533391a01af53d6dbd51b6793c74e8ac81301ae6f1fa18271761a4'
'd5894f7708030ac6f8cc7612b4a29c1fb68aa2d545362017232874579661097ed1257b7de297489a10951716033d522d4ee6c17033009e2a4eaf3cfbdc26091d'
- '59b47dabc2b02a807c978837ab47498dca140f156159ada2c2cdbcf7a912bd95fcaf622bb92bcd585b1c722d4023f50330c4320d59a76e4ba12bb344da43996c')
+ '59b47dabc2b02a807c978837ab47498dca140f156159ada2c2cdbcf7a912bd95fcaf622bb92bcd585b1c722d4023f50330c4320d59a76e4ba12bb344da43996c'
+ 'be566e0e2219e66c734f72a0a1c960589514cda1b4bb40e38e87587ddc1f7f17bb13bb0ab117cace4bcceb900e7e2fd3b4c84818ad77503e514f3974feda7733')
prepare() {
cd "$_githubname-$pkgver" || exit
@@ -27,6 +29,8 @@ prepare() {
--input="$srcdir/$pkgname-[PATCH]-removed-flags-that-are-not-supported-with-swig-4.0.patch"
patch --forward --strip=1 \
--input="$srcdir/$pkgname-[PATCH]-SyntaxWarning:-\"is\"-with-a-literal.patch"
+ patch --forward --strip=1 \
+ --input="$srcdir/$pkgname-[PATCH]-remove-deprecated-getchildren().patch"
}
build() {
@@ -34,6 +38,7 @@ build() {
-B "$_githubname-$pkgver/build" \
-S "$_githubname-$pkgver" \
-DCMAKE_INSTALL_PREFIX:PATH="/usr" \
+ -G "Ninja" \
-Wno-dev
# If compilation seems to stall at 99% for ages, do not abort!