summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Oelmueller2022-03-19 17:30:12 +0100
committerChris Oelmueller2022-03-19 17:30:38 +0100
commitcf3470c3772e9a148351e8a094439e84ca27e809 (patch)
treee8ffcb5e8fd2eeb47d9bea78dbb6320e8b258c9d
parent1eb628b95487c618e6a1f494cc65e1f247b8a3ad (diff)
downloadaur-fife-git.tar.gz
fife-git: Remove no-longer needed SWIG 4 patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--swig4.patch22
3 files changed, 4 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 725f35bcd02b..0c71cc509cd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -29,11 +29,7 @@ pkgbase = fife-git
conflicts = fife
conflicts = fife-svn
source = git+https://github.com/fifengine/fifengine.git
- source = swig4.patch
md5sums = SKIP
- md5sums = 1e915710aea0a9c63a93f13c979e3a7a
sha1sums = SKIP
- sha1sums = f010025945fb392e9d5b89ebd118c049a60eee30
pkgname = fife-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f5f0f0480161..e73d4751768c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,21 +7,17 @@ provides=("fife" "fife-svn")
conflicts=("fife" "fife-svn")
pkgdesc="The mission of the FIFE project is to create a cross platform game creation framework"
url="http://www.fifengine.net/"
-pkgver=0.4.2.r29.g78c07b9a
+pkgver=0.4.2.r33.gf37c31c6
pkgrel=1
arch=('i686' 'x86_64')
license=('LGPL')
depends=('boost' 'fifechan>=0.1.4' 'glew' 'python' 'python-future'
'libgl' 'libogg' 'libpng' 'libvorbis'
'sdl2' 'sdl2_ttf' 'sdl2_image' 'openal' 'tinyxml' 'zlib')
-# # # TO BUILD WITH swig<4 SIMPLY REMOVE THE PATCH FROM prepare() # # #
makedepends=('cmake' 'git' 'swig>=4')
-source=(git+https://github.com/fifengine/fifengine.git
- "swig4.patch")
-md5sums=('SKIP'
- '1e915710aea0a9c63a93f13c979e3a7a')
-sha1sums=('SKIP'
- 'f010025945fb392e9d5b89ebd118c049a60eee30')
+source=(git+https://github.com/fifengine/fifengine.git)
+md5sums=('SKIP')
+sha1sums=('SKIP')
pkgver() {
@@ -29,11 +25,6 @@ pkgver() {
git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/fifengine"
- patch -p1 -i "${srcdir}/swig4.patch"
-}
-
build() {
cd "$srcdir/fifengine"
# [TODO] Due to severe laziness, I have not tested in-source builds yet
diff --git a/swig4.patch b/swig4.patch
deleted file mode 100644
index 1c57e2dc7b0a..000000000000
--- a/swig4.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From d14f232f4cd9a00b05d6872957070e8c020f515d Mon Sep 17 00:00:00 2001
-From: Thomas Kowaliczek-Schmer <linuxdonald@posteo.de>
-Date: Wed, 22 May 2019 16:04:43 +0200
-Subject: [PATCH] removed flags that are not supported with swig 4.0
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 126322ce0..25c695630 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -893,7 +893,7 @@ if(build-python)
- find_package(PythonLibs ${PYTHON_VERSION_STRING} EXACT)
- include_directories(${PYTHON_INCLUDE_PATH})
-
-- set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -keyword -w511 -w473 -w404 -w314)
-+ set(CMAKE_SWIG_FLAGS -fastdispatch -dirvtable -fastproxy -keyword -w511 -w473 -w404 -w314)
-
- set_source_files_properties("${PROJECT_BINARY_DIR}/fife.i" PROPERTIES CPLUSPLUS ON)
- set(FIFE_SOURCES ${FIFE_CORE_SRC})