summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Oelmueller2016-01-10 21:48:54 +0100
committerChris Oelmueller2016-01-10 21:48:54 +0100
commitc8181646e5886ae6897f62160538dfd4914536eb (patch)
tree521ac8ab7c745c5ad4fc3d3cf82735aa4f226d9d
parent22132fab19ba703b2e60034b04d4b27b065ec7f9 (diff)
downloadaur-c8181646e5886ae6897f62160538dfd4914536eb.tar.gz
fife-git: Force swig2 dependency and usage (@stubb @LinuxDonald)
Unfortunately, this forces an unneeded package onto all users who stuck on swig<3.0 for their original SWIG package, but I will assume those users are able to edit PKGBUILD files on their own and tweak accordingly.
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 359bfcc4823d..e915d43b0591 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgver=0.3.4.r293.g50d2f7c
pkgrel=1
arch=('i686' 'x86_64')
license=('LGPL')
-depends=('sdl' 'boost' 'sdl_ttf' 'sdl_image' 'libvorbis' 'libogg' 'openal' 'swig' 'python2' 'zlib' 'libgl' 'libpng' 'tinyxml' 'fifechan-git')
+depends=('sdl' 'boost' 'sdl_ttf' 'sdl_image' 'libvorbis' 'libogg' 'openal' 'swig2' 'python2' 'zlib' 'libgl' 'libpng' 'tinyxml' 'fifechan-git')
makedepends=('scons' 'git')
source=(git+https://github.com/fifengine/fifengine.git)
md5sums=('SKIP')
@@ -22,10 +22,10 @@ pkgver() {
build() {
cd "$srcdir/fifengine"
- scons
+ SWIG="swig-2" scons
}
package() {
cd "$srcdir/fifengine"
- scons install-python --prefix="$pkgdir/usr" --python-prefix="$pkgdir/usr/lib/python2.7/site-packages/"
+ SWIG="swig-2" scons install-python --prefix="$pkgdir/usr" --python-prefix="$pkgdir/usr/lib/python2.7/site-packages/"
}