summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHikari Hayashi2024-01-20 23:28:40 +0800
committerHikari Hayashi2024-01-20 23:30:31 +0800
commitbbda0c376568d6982842e9317542e8a004fa76cc (patch)
treef259c648cd156f75e1004e5df744ff6e62b02394
downloadaur-bbda0c376568d6982842e9317542e8a004fa76cc.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD31
-rw-r--r--figma-agent.install8
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c37523709bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = figma-agent-linux-bin
+ pkgdesc = Figma Agent for Linux (a.k.a. Font Helper)
+ pkgver = 0.3.2
+ pkgrel = 1
+ url = https://github.com/neetly/figma-agent-linux
+ install = figma-agent.install
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ depends = freetype2
+ depends = fontconfig
+ provides = figma-agent-linux
+ conflicts = figma-agent-linux
+ source = https://github.com/neetly/figma-agent-linux/raw/0.3.2/LICENSE
+ source = https://github.com/neetly/figma-agent-linux/raw/0.3.2/figma-agent.service
+ source = https://github.com/neetly/figma-agent-linux/raw/0.3.2/figma-agent.socket
+ sha256sums = a70a5ae5187682046f073f7c6a0387970f1422f211bfab1571c498f91dd72636
+ sha256sums = b65cf8a6538c9aae212e40e396377059b7d24aebb24fa9c38ada2ef74646053f
+ sha256sums = 28740ed93815515f9e2e7f1e71cdf25612515ecf9a78030904bffe83f7fe2e58
+ source_x86_64 = https://github.com/neetly/figma-agent-linux/releases/download/0.3.2/figma-agent-x86_64-unknown-linux-gnu
+ sha256sums_x86_64 = 9c35e0beae50ff92859157853158475e00c270f5f40d48a0ef8d97b11e83302f
+ source_aarch64 = https://github.com/neetly/figma-agent-linux/releases/download/0.3.2/figma-agent-aarch64-unknown-linux-gnu
+ sha256sums_aarch64 = ebad304e64815a69dcfb4a9d51b29419ff3225891bfd3ef1b9a227d995afa52c
+
+pkgname = figma-agent-linux-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..784da6ded503
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+!/figma-agent.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ca47cbc100d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Hikari Hayashi <rev.hikari@gmail.com>
+
+pkgname=figma-agent-linux-bin
+pkgver=0.3.2
+pkgrel=1
+pkgdesc="Figma Agent for Linux (a.k.a. Font Helper)"
+url="https://github.com/neetly/figma-agent-linux"
+license=(MIT)
+arch=(x86_64 aarch64)
+depends=(freetype2 fontconfig)
+makedepends=()
+provides=(figma-agent-linux)
+conflicts=(figma-agent-linux)
+source=("https://github.com/neetly/figma-agent-linux/raw/$pkgver/LICENSE"
+ "https://github.com/neetly/figma-agent-linux/raw/$pkgver/figma-agent.service"
+ "https://github.com/neetly/figma-agent-linux/raw/$pkgver/figma-agent.socket")
+source_x86_64=("https://github.com/neetly/figma-agent-linux/releases/download/$pkgver/figma-agent-x86_64-unknown-linux-gnu")
+source_aarch64=("https://github.com/neetly/figma-agent-linux/releases/download/$pkgver/figma-agent-aarch64-unknown-linux-gnu")
+sha256sums=('a70a5ae5187682046f073f7c6a0387970f1422f211bfab1571c498f91dd72636'
+ 'b65cf8a6538c9aae212e40e396377059b7d24aebb24fa9c38ada2ef74646053f'
+ '28740ed93815515f9e2e7f1e71cdf25612515ecf9a78030904bffe83f7fe2e58')
+sha256sums_x86_64=('9c35e0beae50ff92859157853158475e00c270f5f40d48a0ef8d97b11e83302f')
+sha256sums_aarch64=('ebad304e64815a69dcfb4a9d51b29419ff3225891bfd3ef1b9a227d995afa52c')
+install=figma-agent.install
+
+package() {
+ install -Dm755 "./figma-agent-$CARCH-unknown-linux-gnu" "$pkgdir/usr/bin/figma-agent"
+ install -Dm644 "./LICENSE" "$pkgdir/usr/share/licenses/figma-agent/LICENSE"
+ install -Dm644 "./figma-agent.service" "$pkgdir/usr/lib/systemd/user/figma-agent.service"
+ install -Dm644 "./figma-agent.socket" "$pkgdir/usr/lib/systemd/user/figma-agent.socket"
+}
diff --git a/figma-agent.install b/figma-agent.install
new file mode 100644
index 000000000000..5c13e54b2751
--- /dev/null
+++ b/figma-agent.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "Please run this command manually to enable the socket:"
+ echo "$ systemctl --user enable --now figma-agent.socket"
+}
+
+post_upgrade() {
+ post_install
+}