summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChugunov Roman2019-12-06 12:16:27 +0300
committerChugunov Roman2019-12-06 12:16:27 +0300
commitd7d21a34c545761c53f62f2fa52d1ba4641dab1a (patch)
treee9ce314af2bef50c40f73c29aba49d4c7fe77d8f
parent5fe1bd5d66f5a43871cbca7d40419a1734e7349b (diff)
downloadaur-d7d21a34c545761c53f62f2fa52d1ba4641dab1a.tar.gz
Replace pacman on zip archive
-rw-r--r--.SRCINFO18
-rw-r--r--128x128.pngbin0 -> 10400 bytes
-rw-r--r--256x256.pngbin0 -> 28203 bytes
-rw-r--r--48x48.pngbin0 -> 5990 bytes
-rw-r--r--64x64.pngbin0 -> 6342 bytes
-rw-r--r--PKGBUILD37
-rw-r--r--figma.desktop10
7 files changed, 52 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d48dd483965..abff512b6239 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,25 @@
pkgbase = figma-linux
pkgdesc = The collaborative interface design tool. Unofficial Figma desktop client for Linux
pkgver = 0.6.1
- pkgrel = 11
+ pkgrel = 12
url = https://github.com/Figma-Linux/figma-linux
arch = x86_64
license = GPL2
conflicts = figma-bin
replaces = figma-bin
- noextract = figma-linux-0.6.1.pacman
- source = https://github.com/Figma-Linux/figma-linux/releases/download/v0.6.1/figma-linux-0.6.1.pacman
- sha256sums = 9618a2694acde6af5cc4d95346f5d2694cffb8fd73b34667ef42aaea9baed534
+ noextract = figma-linux-0.6.1.zip
+ source = https://github.com/Figma-Linux/figma-linux/releases/download/v0.6.1/figma-linux-0.6.1.zip
+ source = figma.desktop
+ source = 48x48.png
+ source = 64x64.png
+ source = 128x128.png
+ source = 256x256.png
+ sha256sums = 2ee8b30221228739a26ccd4a0663fc16274899032203c6533773cddaeb5f389a
+ sha256sums = 2751b7d32601c695cca42ca8a09b4d0a4317afa36af797b5ede621d045e0570f
+ sha256sums = 72d0c9df5b81a7666a05751a38fe096f629096be73792355f6069024cf7c0412
+ sha256sums = 780219a3792c5c4160829e7a8023e16f78e12c807762d7217a9db90e43a3f777
+ sha256sums = 86f34a8d9ddfdcfad5cc5e170a729cee7bca61102fbe0b10746b7f83b19d45bc
+ sha256sums = 1db635df7d84f73694303eba423acd75da892e084cf35c4e260bd5c6b56fcc1e
pkgname = figma-linux
diff --git a/128x128.png b/128x128.png
new file mode 100644
index 000000000000..e0fb3a24e057
--- /dev/null
+++ b/128x128.png
Binary files differ
diff --git a/256x256.png b/256x256.png
new file mode 100644
index 000000000000..0a319dc9e3a3
--- /dev/null
+++ b/256x256.png
Binary files differ
diff --git a/48x48.png b/48x48.png
new file mode 100644
index 000000000000..7558f370b06d
--- /dev/null
+++ b/48x48.png
Binary files differ
diff --git a/64x64.png b/64x64.png
new file mode 100644
index 000000000000..59cacbda4538
--- /dev/null
+++ b/64x64.png
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
index 9fba14d2166b..66ee45fed056 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,43 @@
pkgname="figma-linux"
pkgver="0.6.1"
-pkgrel="11"
+pkgrel="12"
pkgdesc="The collaborative interface design tool. Unofficial Figma desktop client for Linux"
arch=("x86_64")
url="https://github.com/Figma-Linux/figma-linux"
license=('GPL2')
conflicts=("figma-bin")
replaces=("figma-bin")
-source=("https://github.com/Figma-Linux/figma-linux/releases/download/v${pkgver}/figma-linux-${pkgver}.pacman")
-noextract=("figma-linux-${pkgver}.pacman")
-sha256sums=("9618a2694acde6af5cc4d95346f5d2694cffb8fd73b34667ef42aaea9baed534")
+source=("https://github.com/Figma-Linux/figma-linux/releases/download/v${pkgver}/figma-linux-${pkgver}.zip"
+ "figma.desktop"
+ "48x48.png"
+ "64x64.png"
+ "128x128.png"
+ "256x256.png")
+depends=("unzip")
+noextract=("figma-linux-${pkgver}.zip")
+sha256sums=("2ee8b30221228739a26ccd4a0663fc16274899032203c6533773cddaeb5f389a"
+ "2751b7d32601c695cca42ca8a09b4d0a4317afa36af797b5ede621d045e0570f"
+ "72d0c9df5b81a7666a05751a38fe096f629096be73792355f6069024cf7c0412"
+ "780219a3792c5c4160829e7a8023e16f78e12c807762d7217a9db90e43a3f777"
+ "86f34a8d9ddfdcfad5cc5e170a729cee7bca61102fbe0b10746b7f83b19d45bc"
+ "1db635df7d84f73694303eba423acd75da892e084cf35c4e260bd5c6b56fcc1e")
-prepare() {
- cd "${srcdir}"
- sudo pacman -U "figma-linux-${pkgver}.pacman"
-}
+prepare() {}
package() {
cd "${srcdir}"
+ install -D "${srcdir}"/figma.desktop "${pkgdir}"/usr/share/applications/figma.desktop
+ install -D "${srcdir}"/256x256.png "${pkgdir}"/usr/share/pixmaps/figma.png
+
+ for size in 48 64 128 256; do
+ install -D "${srcdir}/${size}x${size}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/figma.png"
+ done
+
+ mkdir -p "${pkgdir}/opt/${pkgname}"
+ unzip -q "figma-linux-${pkgver}.zip" -d "${pkgdir}/opt/${pkgname}"
+
mkdir -p "${pkgdir}/usr/bin"
- ln -s "/opt/${pkgname}/figma-linux" "${pkgdir}/usr/bin/figma-linux"
+ ln -s "/opt/${pkgname}/figma-linux" "${pkgdir}/usr/bin/figma"
}
diff --git a/figma.desktop b/figma.desktop
new file mode 100644
index 000000000000..d39ff0dabe48
--- /dev/null
+++ b/figma.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=figma-linux
+Comment=Unofficial desktop application for linux
+Exec="/opt/figma-linux/figma-linux" %U
+Terminal=false
+Type=Application
+Icon=figma-linux
+StartupWMClass=figma-linux
+Categories=Graphics;
+MimeType=application/figma;x-scheme-handler/figma;